Plugins for 2.0.3

General support for problems installing or using Deluge
bro
Top Bloke
Top Bloke
Posts: 360
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: Plugins for 2.0.3

Postby bro » Mon Oct 14, 2019 2:26 pm

watermark86 wrote:Thank you very much for getting this updated.

Matched files seem to not actually be added for download. It shows in the log as "adding", but then no file is actually added for download. Manually copying and pasting the referenced magnet link into deluge works fine. This issue occurs no matter how I try to add the link from an RSS feed (ie. "Run this subscription", "Add torrent", etc). Log snippet below.

If it matters, I'm running deluge daemon in docker and connecting to the daemon using the headless client (docker image "linuxserver/deluge"). The docker container is running 18.04.

-----

(2019-10-12T19:47:23): 40 items in feed, 2 matches the filter.
(2019-10-12T19:47:23): isodate_to_datetime error:
(2019-10-12T19:47:23): Adding magnet: 'magnet:?xt=urn:btih:9637940C41E ... ' (I truncated the magnet link)


Hmm..looks like a bug with magnet links then. The rss feed parser library had to be replaced, so I'm not surprised there are some issues. I'd need a feed with torrent links to test this though...
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.

User avatar
gderf
Seeder
Seeder
Posts: 155
Joined: Sat Jun 18, 2016 1:32 am

Re: Plugins for 2.0.3

Postby gderf » Mon Oct 14, 2019 2:38 pm

Some of the feeds I use that work fine with the old version of the plugin:

https://yts.ag/rss/0/720p/all/0
http://rarbg.to/rssdd.php?categories=45

bro
Top Bloke
Top Bloke
Posts: 360
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: Plugins for 2.0.3

Postby bro » Wed Oct 16, 2019 5:02 am

watermark86 wrote:Thank you very much for getting this updated.

Matched files seem to not actually be added for download. It shows in the log as "adding", but then no file is actually added for download. Manually copying and pasting the referenced magnet link into deluge works fine. This issue occurs no matter how I try to add the link from an RSS feed (ie. "Run this subscription", "Add torrent", etc). Log snippet below.


There was a bug when adding magnet links which is fixed in v2.1.0
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 19 guests