DeprecationWarning: integer argument expected

General support for problems installing or using Deluge
Shenk

DeprecationWarning: integer argument expected

Postby Shenk » Sat Jun 09, 2007 1:08 pm

I've installed this package.
http://download.deluge-torrent.org/test ... _amd64.deb

When I try to run deluge.
It's the messages shown.

Code: Select all

no existing Deluge session
deluge_core; using libtorrent 0.13.0.0. Compiled with NDEBUG value: 1
Applying preferences
/var/lib/python-support/python2.5/deluge/core.py:715: DeprecationWarning: integer argument expected, got float
  PREF_FUNCTIONS[pref](self.get_pref(pref))
Traceback (most recent call last):
  File "/usr/bin/deluge", line 63, in <module>
    interface = deluge.interface.DelugeGTK()
  File "/var/lib/python-support/python2.5/deluge/interface.py", line 89, in __init__
    '%s %s'%(common.PROGRAM_NAME, common.PROGRAM_VERSION), common.CONFIG_DIR)
  File "/var/lib/python-support/python2.5/deluge/core.py", line 215, in __init__
    self.state = pickle.load(pkl_file)
  File "/usr/lib/python2.5/pickle.py", line 1370, in load
    return Unpickler(file).load()
  File "/usr/lib/python2.5/pickle.py", line 858, in load
    dispatch[key](self)
  File "/usr/lib/python2.5/pickle.py", line 1069, in load_inst
    klass = self.find_class(module, name)
  File "/usr/lib/python2.5/pickle.py", line 1124, in find_class
    __import__(module)
ImportError: No module named deluge

No programe window appear.
What's wrong with it?

markybob
Compulsive Poster
Compulsive Poster
Posts: 1230
Joined: Thu May 24, 2007 11:27 pm
Location: Chicago, IL, USA
Contact:

Re: DeprecationWarning: integer argument expected

Postby markybob » Sat Jun 09, 2007 8:03 pm

Shenk wrote:I've installed this package.
http://download.deluge-torrent.org/test ... _amd64.deb

When I try to run deluge.
It's the messages shown.

Code: Select all

no existing Deluge session
deluge_core; using libtorrent 0.13.0.0. Compiled with NDEBUG value: 1
Applying preferences
/var/lib/python-support/python2.5/deluge/core.py:715: DeprecationWarning: integer argument expected, got float
  PREF_FUNCTIONS[pref](self.get_pref(pref))
Traceback (most recent call last):
  File "/usr/bin/deluge", line 63, in <module>
    interface = deluge.interface.DelugeGTK()
  File "/var/lib/python-support/python2.5/deluge/interface.py", line 89, in __init__
    '%s %s'%(common.PROGRAM_NAME, common.PROGRAM_VERSION), common.CONFIG_DIR)
  File "/var/lib/python-support/python2.5/deluge/core.py", line 215, in __init__
    self.state = pickle.load(pkl_file)
  File "/usr/lib/python2.5/pickle.py", line 1370, in load
    return Unpickler(file).load()
  File "/usr/lib/python2.5/pickle.py", line 858, in load
    dispatch[key](self)
  File "/usr/lib/python2.5/pickle.py", line 1069, in load_inst
    klass = self.find_class(module, name)
  File "/usr/lib/python2.5/pickle.py", line 1124, in find_class
    __import__(module)
ImportError: No module named deluge

No programe window appear.
What's wrong with it?

remove your config dir. rm -rf ~/.config/deluge


Return to “Support”

Who is online

Users browsing this forum: Google [Bot] and 11 guests