UPNP not working? Other ways to set advertised server address?

General support for problems installing or using Deluge
cross
New User
New User
Posts: 6
Joined: Fri May 08, 2015 3:15 am
OS or Distro: FreeBSD

UPNP not working? Other ways to set advertised server address?

Postby cross » Mon Jun 18, 2018 3:31 am

I have deluge 1.3.15 running on FreeBSD host behind a NAT router I run myself. I have miniupnpd running, and configured to allow my deluge host to request ports in the same range configured in deluge (lets say 45600 - 45700). Assuming I did that right. (in Network preferences, for both Incoming and Outgoing Ports, I have "From: 45600" and "To: 45700", with "Use Random Ports" _not_ checked.). I also have UPnP checked at the bottom, and none of the other "Network Extras."

On at least one tracker I use, if I ask it about my connect ability, it reports that my client is not able to accept incoming connections, and it shows by IP address as my _internal_ IP address behind my NAT/router, and shows a port number _not_ in the range above...

And, if I look at the packet filter rules put in place on my router by miniupnpd, I see no rules for my deluge server.

Am I not telling deluge correctly to use UPnP to find an outside routable address? Or is there some other reason it is advertising it's internal IP address to outside trackers I'm connected to?

Thanks. Ask any questions if I didn't provide enough information, but I'm a little out of ideas.

cross
New User
New User
Posts: 6
Joined: Fri May 08, 2015 3:15 am
OS or Distro: FreeBSD

Re: UPNP not working? Other ways to set advertised server address?

Postby cross » Fri Jul 06, 2018 11:59 am

No-one can help here? Is there another place I should ask? Thanks...

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: UPNP not working? Other ways to set advertised server address?

Postby mhertz » Fri Jul 06, 2018 12:23 pm

This forum is rather "slow" strangely, even though deluge is extremely popular on seedoxes etc, but oh well.

Sorry I do not know why the upnp seem to not work on your setup, but I would first set a fixed port just for testing(disable random and set "from and to" same port) and test e.g. here if you're connectable: http://canyouseeme.org/ If all else fails you can just simply forward the port(-range) directly instead.

About the tracker using your local IP, then I suspect it's because of an IPv6 tracker extension which sends extra fields in the tracker-announce(&IPV4= and/or &IPv6=). Avoding this should be possible by using ltconfig plugin and enabling anonymous_mode, but I believe there where an issue with this where it didn't work and was fixed in later libtorrent-version, but you can test using http://ipmagnet.services.cbcdn.com (if you're affected it will show as "IP: public, local" instead of just showing public IP). There's also a setting(announce_ip) in libtorrent you can use from ltconfig to send your actual IP to the tracker instead of what it thinks, if all else fails.

Good luck! :)

Edit: to check which port deluge uses(I can't remember if the GTK-UI lists this too), and upnp status, then you can check the log for it, by starting deluged like this instead:

Code: Select all

deluged -L debug -l deluged.log

You can then e.g.:

Code: Select all

grep -i -e port -e upnp deluged.log

I seem to recall it's been reported before that deluge doesn't use the port defined to use, for some reason.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 6 guests