Page 1 of 1

Unreliable and inconsistent seeding between test server and test client

Posted: Sat May 19, 2018 8:59 pm
by utaysidun

First off, I'm not sure if my problem is specific to Deluge. I'm very confused about these issues as they don't make any sense to me and are very inconsistent, so I don't know if it's an issue with Deluge, with my VPN, or maybe just normal BitTorrent operation that I just don't understand. I have also tested a bit with other BitTorrent clients, all having similarly inconsistent problems. I'll just try my luck here first though because I did most of my testing with Deluge, which is by far my favorite client.

I am currently setting up a system on my home server as a seedbox with Deluge. This server is routing all of its traffic through a torrent-friendly VPN (TorGuard) via OpenVPN (instead of Deluge's proxy options). I have set up port-forwarding in the VPN and configured Deluge to use the forwarded ports as static "Incoming Ports". Deluge's active port check succeeds and I have independently checked that the ports are open. Deluge on the server has DHT and PEX enabled, with UPnP, LSD and NAT-PMP disabled. For testing, I am seeding a torrent that has no other seeders most of the time (so it's not a problem of overseeding). There are no other torrents on the server.

Now, on another machine ("client") I use Deluge with the same settings to download the torrent that the server is seeding (via magnet link). That client is on a different network than the server. I have tried the client in multiple configurations: Directly connected to my ISP with port forwarding enabled, another ISP without port-forwarding and various different VPN connections without port-forwarding. All of these configurations had a number of DHT nodes appear in the status bar on both client and server. I hoped that the client would just start downloading from my server after a few seconds. Unfortunately, it behaved differently every time I tried it:

Most of the times I started up the client and added the torrent, it did at some point have my seeding server in the peer list briefly with 0% progress, but then removed it again without downloading anything. Sometimes my client would download from another seeder if one was available, but not from my server. Sometimes it wouldn't download anything. Sometimes (after 20 minutes or more of me doing absolutely nothing), my server would suddenly appear again and the client would actually download from it. Whenever that happened, I removed the torrent from the client and added it again. After re-adding the same torrent, the download from my server would often begin again very quickly (a few seconds). Sometimes though I had to wait another 20 minutes, other times nothing would happen at all. I also tried restarting the Deluge daemon on the server while it was uploading to my client. After the restart, the client would usually not connect to the server again (maybe it does after many hours, I haven't waited that long yet).

I have tried basically all combinations of VPN, local network and internet with lots of restarting Deluge on both client and server, and it just doesn't make sense to me. Sometimes it didn't even work when no VPN was involved if they were on different local networks. The only thing that worked consistently is when client and server were in the same local network and LSD was enabled - then they connected to each other very quickly via a local IP address. Both client and server also have no problems downloading some well-known public torrents with many seeders.

I'm using Deluge 1.3.13 (libtorrent on Debian in daemon-mode on the server, and 1.3.10 (libtorrent on the client. I might have tried some other versions on different client machines as well in my desperate attempts to get any consistent results.

Does anybody have the slighest clue what's going on, or where I might get more help about these issues?