Headphones can't connect to Deluge

General support for problems installing or using Deluge
Posts: 11
Joined: Mon Jan 23, 2017 4:13 pm

Headphones can't connect to Deluge

Postby Pyrrhic » Mon May 14, 2018 9:58 am

Hi all,

I asked about this over on the Headphones git issues tracker, but I think this almost certainly a problem with my config of Deluge, so thought I'd best come here.

I've tried to set Deluge up as the download client for Headphones (https://github.com/rembo10/headphones), but it's not able to send torrents to Deluge - this is the error log I get in Headphones:

2018-03-30 15:12:11 ERROR Deluge: WebUI does not contain daemons
2018-03-30 15:12:11 DEBUG Deluge: Connection result: None, Error: {u'message': u'Not authenticated', u'code': 1}
2018-03-30 15:12:11 DEBUG Deluge: Authentication cookies: {'_session_id': 'REMOVED'}
2018-03-30 15:12:11 DEBUG Deluge: Authentication result: True, Error: None
2018-03-30 15:12:11 DEBUG Deluge: FYI no SSL certificate configured
2018-03-30 15:12:11 DEBUG Deluge: Using password ********
2018-03-30 15:12:11 DEBUG Deluge: Authenticating...
2018-03-30 15:12:11 DEBUG Deluge: addTorrent Authentication
2018-03-30 15:12:11 INFO Sending torrent to Deluge

The Headphones developer got me a little closer to a solution I think - he asked me what happened when I tried to navigate to http://localhost:7055 (the nonstandard port I use for Deluge) on the machine that's running Deluge. When I do that, I get a blank page, but the tab title changes to reflect what you're normally see on connection to Deluge (e.g Deluge and version number) - here's the source code of the page I get:

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
      <title>Deluge: Web UI 1.3.15</title>
      <link rel="shortcut icon" href="/deluge/icons/deluge.png" type="image/png" />
      <link rel="icon" href="/deluge/icons/deluge.png" type="image/png" />
      <link rel="apple-touch-icon-precomposed" media="screen and (resolution: 163dpi)" href="/deluge/icons/apple-pre-57.png" />
      <link rel="apple-touch-icon-precomposed" media="screen and (resolution: 132dpi)" href="/deluge/icons/apple-pre-72.png" />
      <link rel="apple-touch-icon-precomposed" media="screen and (resolution: 326dpi)" href="/deluge/icons/apple-pre-114.png" />
      <!-- Stylesheets -->
      <link rel="stylesheet" type="text/css" href="/deluge/css/ext-all-notheme.css" />
      <link rel="stylesheet" type="text/css" href="/deluge/themes/css/xtheme-gray.css" />
      <link rel="stylesheet" type="text/css" href="/deluge/css/ext-extensions.css" />
      <link rel="stylesheet" type="text/css" href="/deluge/css/deluge.css" />

      <script type="text/javascript">
      deluge = {
         author: 'Damien Churchill <damoxc@gmail.com>',
         version: '1.3.15',
         config: {"sidebar_show_zero": false, "show_session_speed": true, "first_login": false, "theme": "gray", "base": "/deluge/", "sidebar_multiple_filters": true}

      <!-- Javascript -->
      <script type="text/javascript" src="/deluge/gettext.js"></script>
      <script type="text/javascript" src="/deluge/js/ext-base.js"></script>
      <script type="text/javascript" src="/deluge/js/ext-all.js"></script>
      <script type="text/javascript" src="/deluge/js/ext-extensions.js"></script>
      <script type="text/javascript" src="/deluge/js/deluge-all.js"></script>
      <script type="text/javascript" src="/deluge/js/execute/execute.js"></script>
      <script type="text/javascript" src="/deluge/js/label/label.js"></script>
      <script type="text/javascript">
         Deluge.debug = false;
      <div style="background-image: url('/deluge/themes/images/default/tree/loading.gif');"></div>

      <!-- Preload icon classes -->
      <div class="ext-mb-error"></div>
      <div class="icon-ok"></div>

Other relevant info:

  • I'm running Deluge 1.3.15 on Ubuntu 16.04 LTS
  • I'm running Deluge through a nginx reverse proxy - no problems accessing the web UI with my dynamic dns address/deluge
  • the reverse proxy code I'm using is the code off the Deluge wiki
  • I tested the other day, and I was successfully able to get Headphones talking to Transmission and sending torrents, running through the same reverse proxy - which suggests to me the problem must be with my Deluge configuration rather than the reverse proxy

Any suggestions folks? It's not something I expect to make much use of, but it's just eating away at me knowing there's an issue there that I can't solve with this. Thanks!

Posts: 11
Joined: Mon Jan 23, 2017 4:13 pm

Re: Headphones can't connect to Deluge

Postby Pyrrhic » Mon May 21, 2018 12:01 pm

UPDATE: I haven't made any progress in troubleshooting Headphones, but I *did* discover there's another similar program called Lidarr, which is yet another program in the Sonarr/Radarr ilk but for music:


Predictably given the shared codebase, it works just fine - so with some regret (as I'm sure Headphones is very nice and all) I'll probably just go with the path of least resistance and user Lidarr :)

Return to “Support”

Who is online

Users browsing this forum: No registered users and 9 guests