[Solved] Torrents no longer download

General support for problems installing or using Deluge
3v4q
New User
New User
Posts: 3
Joined: Fri Mar 02, 2018 2:58 am
OS or Distro: Arch Linux ARM

[Solved] Torrents no longer download

Postby 3v4q » Sat Mar 03, 2018 12:37 am

Hi,

I've got a Raspberry Pi 3 running Arch Linux ARM with Deluge 1.3.15 and libtorrent 1.1.6. I had been using this setup successfully for several weeks until last weekend when I noticed all of my torrents sitting at 0% progress despite having plenty of seeders.

The problem occurs regardless of which torrents are active. I was able to download the same torrents on another device on my network with no issues. I was also able to download the same torrents with transmission on the Raspberry Pi. I tried downgrading libtorrent to 1.1.5 (as well as boost-libs to 1.65.1) but that did not help. I tried setting deluge's logging level to debug but it didn't provide any useful information as far as I could tell. I had not upgraded any software on the device before it stopped downloading. I also ran df and verified that I was not out of disk space.

At this point I am out of ideas on how to troubleshoot this issue. I would be grateful for any suggestions and am happy to provide more details if needed.

Edit: I also wanted to mention that I am using a proxy via SOCKS5 for all four proxy settings. This is the same as on the other device that was able to download properly.
Last edited by 3v4q on Sat Mar 03, 2018 6:41 pm, edited 1 time in total.

User avatar
gderf
Leecher
Leecher
Posts: 83
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

Re: Torrents no longer download

Postby gderf » Sat Mar 03, 2018 1:01 pm

Try disabling the proxy temporarily. If that solves it find out why.

3v4q
New User
New User
Posts: 3
Joined: Fri Mar 02, 2018 2:58 am
OS or Distro: Arch Linux ARM

Re: Torrents no longer download

Postby 3v4q » Sat Mar 03, 2018 6:23 pm

I disabled the proxy by using the following for all four proxy settings in core.conf:

Code: Select all

"username": "",
"password": "",
"type": 1,
"hostname": "",
"port": 8080

This does not solve the problem: a torrent that I am able to download in a few minutes with transmission is indefinitely stuck at 0% progress in deluge despite having seeders.

It may be worth noting that when I restart the deluge daemon and run deluge-console info, it sometimes shows small progress around 100KB before going back to 0.

3v4q
New User
New User
Posts: 3
Joined: Fri Mar 02, 2018 2:58 am
OS or Distro: Arch Linux ARM

Re: Torrents no longer download

Postby 3v4q » Sat Mar 03, 2018 6:40 pm

Well, I have fixed my problem and I feel like an idiot. My download folder was not set to the right user and group.

Out of curiosity, does Deluge log anything when it fails to write to a location that it does not have permission to access? I just wonder if I would have found this through Deluge eventually.

shamael
Super Seeder
Super Seeder
Posts: 383
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: [Solved] Torrents no longer download

Postby shamael » Mon Mar 05, 2018 9:02 am

You have to set the verbosity of the logs (see the wiki) or start a debug session. I've never looked for such output so cannot confirm however


Return to “Support”

Who is online

Users browsing this forum: No registered users and 3 guests