“Missing or invalid torrent data!"

General support for problems installing or using Deluge
migasmike
New User
New User
Posts: 2
Joined: Wed Jan 24, 2018 8:35 pm
OS or Distro: Raspi Pi Debian

“Missing or invalid torrent data!"

Postby migasmike » Wed Jan 24, 2018 9:30 pm

Hello,

I have used Deluge with Daemon in a Raspberry PI 3 (without Web console). Every time I restart the Raspberry PI 3 for some reason and I start again Deluge the torrent appears in red with the error message: “Missing or invalid torrent data!". I have to use the “Force Re-ckeck” too reactivated all torrents.

Already try a lot of installations, but without success.

I will describe here step by step, my installation of Deluge


In bash

pi@raspberrypi:~ $ sudo bash

root@raspberrypi:/home/pi# aptitude update
root@raspberrypi:/home/pi# aptitude upgrade
root@raspberrypi:/home/pi# aptitude install deluge deluged deluge-console
root@raspberrypi:/home/pi# nano /etc/default/deluged

# Defaults for deluged initscript
# sourced by /etc/init.d/deluged
# change to 1 to enable daemon
ENABLE_DELUGED=1 (change ENABLE_DELUGED=0 to ENABLE_DELUGED=1)

Save it

Reboot (reboot Raspberry)

Open Deluge (Graphic Mode)

I Disable the Classic Mode of Deluge (it´s necessary restart the Deluge)

root@raspberrypi:/home/pi# killall deluged

root@raspberrypi:/home/pi# nano /var/lib/deluged/config/auth

Put this line: user:assword:level

localclient:3f32e493915ea5c1be2fe38912acc6222c5275eb:10
user(pi):password(raspberry):level (10) = FULL ACESS

Save it

root@raspberrypi:/home/pi# deluged
root@raspberrypi:/home/pi# deluge-console

I put the two following lines and type exit

config -s allow_remote True
config allow_remote
exit


Open Deluge (Graphic Mode)

In Connection Manager


Enable – “Automatically connect to select host on startup
Enable – “Automatically


Add localhost


localhost


pi
raspberry (password of the raspberry, account pi)

Exit Deluge (Graphic Mode)

Reboot Raspberry If the status of pi@localhost:58846 change to green in the Connection Manager the Daemon is OK

Because I have external usb Hard Drive connect to Raspberry in NTFS file system, I do the this:


Write in NTFS file System

root@raspberrypi:/home/pi# sudo bash
root@raspberrypi:/home/pi# aptitude update
root@raspberrypi:/home/pi# aptitude install ntfs-3g

Because I had some problems with denied torrent files in the external usb disk, I do this:

root@raspberrypi:/home/pi# chmod 755 -R /media/pi
root@raspberrypi:/home/pi# chown pi:pi -R /media/pi
root@raspberrypi:/home/pi# adduser debian-deluged pi

My big question is why every time I restart the Raspberry PI 3 for some reason and I start again Deluge the torrent appears in red with the error message: “Missing or invalid torrent data!". I have to use the “Force Re-ckeck” too reactivated all torrents. Why this happens?’

I can find any manual/tutorial on the Web that works fine and show it step-by-step how to do it. All manual/tutorial that I find have problems.

I need your help!

Thanks
Mike

shamael
Super Seeder
Super Seeder
Posts: 359
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: “Missing or invalid torrent data!"

Postby shamael » Thu Jan 25, 2018 8:12 am

Hi,

Do you start Deluge automatically in the boot sequence?
It sounds like viewtopic.php?f=7&t=48629&p=226704&hilit=mount#p226704
The disk is mounted but the filesystem is not yet accessible at the time Deluge starts, I adapted the service to wait for the filesystem prior to start Deluge.

About tutorial check the support page on this website, especially the PPA parts. The Deluge team maintain a repository with the last version, you simply have to add it.

#Installation
-based on Jessie follow the PPA tutorial: http://dev.deluge-torrent.org/wiki/Inst ... ian/Jessie
-based on Stretch read my post: viewtopic.php?f=7&t=54783&p=227568&hilit=stretch#p227568

The actual distributed version is Deluge 1.3.15 with Libtorrent 1.0.11

#Service configuration
http://dev.deluge-torrent.org/wiki/User ... ce/systemd
(it contains the wait for disk fix already)

migasmike
New User
New User
Posts: 2
Joined: Wed Jan 24, 2018 8:35 pm
OS or Distro: Raspi Pi Debian

Re: “Missing or invalid torrent data!"

Postby migasmike » Thu Jan 25, 2018 10:39 am

shamael wrote:Hi,

Do you start Deluge automatically in the boot sequence?


Hi shamael,

I have the Deluge 1.3.15 with Libtorrent 1.0.11
I have just have the Daemon installed like in this tutorial: https://www.howtogeek.com/142044/how-to ... rrent-box/
I don´t have any script to force Deluge to start.

I supposed with this kind of installation of the Deluge, the program starts in background, Without the graphic mode.
I´m wrong ?


It sounds like viewtopic.php?f=7&t=48629&p=226704&hilit=mount#p226704
The disk is mounted but the filesystem is not yet accessible at the time Deluge starts, I adapted the service to wait for the filesystem prior to start Deluge.


I have to check this part...

About tutorial check the support page on this website, especially the PPA parts. The Deluge team maintain a repository with the last version, you simply have to add it.

#Installation
-based on Jessie follow the PPA tutorial: http://dev.deluge-torrent.org/wiki/Inst ... ian/Jessie
-based on Stretch read my post: viewtopic.php?f=7&t=54783&p=227568&hilit=stretch#p227568

The actual distributed version is Deluge 1.3.15 with Libtorrent 1.0.11


The Jessie version is this one: http://dev.deluge-torrent.org/wiki/Inst ... ian/Jessie ?
-based on Stretch read my post: i can´t find this post

#Service configuration
http://dev.deluge-torrent.org/wiki/User ... ce/systemd
(it contains the wait for disk fix already)


I have to check this part... too

I have to say that i´m just a beginner in Linux stuff.

Just one more thing: when i use the Deluge without the Daemon (with the Classic Mode Enable on the interface), and i launch manually
after a reboot of the program or the raspberry, i don´t have any problem with the torrents
( this problem don´t appears: error message: “Missing or invalid torrent data!")

Thanks,
Mike

shamael
Super Seeder
Super Seeder
Posts: 359
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: “Missing or invalid torrent data!"

Postby shamael » Thu Jan 25, 2018 5:26 pm

Hi

You've the right version already, good point. Without the daemon configuration so just after Deluge installation you can use it as an application, starting when you click on it (or by typing "deluged" in command line) or you can start the Deluge service (named "deluged") at boot. Just like a service under Windows so. Starting Deluge as an application should work fine as you said, the NTFS filesystem had time to be accessible but with a service it starts way earlier in the process, creating for example the Deluged daemon the inability to reach/check the file when it start.

In your tutorial there is "Step Five: Configure Deluge to Run on Startup" which is done by an outdated way. Best is to remove these steps (in /etc/rc.local) and configure the service in systemd (as in the systemd wiki).

To resume: the Deluge installation is done and you have to decide if you start it automatically (and the web interface) or not. With an RPI and Debian, a typical usage is to start Deluged automatically and connect it remotely from another computer on the network (in the non classic mode so). I prefer to configure the web interface too in case of problem, If so multiple way to check if Deluge is up or not and the possibility to check torrent with a iPad or else.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 5 guests