Deluge stops transferring periodically

General support for problems installing or using Deluge
New User
New User
Posts: 1
Joined: Thu Dec 28, 2017 4:14 pm
OS or Distro: Ubuntu Server 16.04

Deluge stops transferring periodically

Postby pencil » Thu Dec 28, 2017 4:53 pm

Every minute or two deluge drops all connections, hangs out for like 30 seconds, then continues along like nothing was wrong.

I'm running Deluge 1.3.15 on Ubuntu Server 16.04. It is running headless on a machine with a quad core processor and 4GB of ram, and with deluge-web alongside to provide the user interface. The files being seeded/downloaded are stored on a NAS on the same local network, mounted via SMB/CIFS. During these drop-outs, I'm not seeing any increase in CPU, disk, or network traffic. In fact, all 3 drop for the duration of the hang.

I run a dedicated pfSense box as my firewall/router/NAT. Here's a gif from that box, running darkstat, monitoring two entire drop outs. This gif runs about 12 seconds, then loops, but represents ~4 minutes of real-time:

This gif was taken while I was downloading one torrent and seeding a number of others. You can see the drop applies to both the inbound and outbound traffic. If you look at the graph on the right, you can see this pattern of drop-outs every couple of minutes has been happening for the hour leading up to this moment as well.

I don't see how it could be internet connection, because during these drops in traffic, I can run speed tests and download files no problem, and can easily prove that I've got lots of headroom there.

This isn't something new, I've been seeing this all year.

In terms of the load on Deluge, I'm currently seeding 22 torrents, for a total of ~6TB of data spread across ~75k files, which is roughly typical of how my box runs most of the time, occasionally downloading something new, but mostly seeding.

I've heard reports that other people see regular drop-outs like this as well, and some claim this happens on other bittorrent software as well as Deluge.

So does anyone know what might be causing this? Is this something others have seen? Is there any additional diagnostic information I can provide from my running instance of Deluge?

Posts: 18
Joined: Thu Jan 15, 2015 6:39 am
OS or Distro: debian

Re: Deluge stops transferring periodically

Postby scoobynz » Sat Jan 06, 2018 2:03 pm

Have you installed the ltconfig plugin? When I have had this issue in the past I've solved it by installing this plugin and selecting the "High Performance Seed" option (you can make tweaks to this as well, for e.g. max downloads is only 3, so I increase this, and I manually change the user-agent back to deluge etc).

Return to “Support”

Who is online

Users browsing this forum: No registered users and 2 guests