Linux, Ports, connection

General support for problems installing or using Deluge
New User
New User
Posts: 1
Joined: Sun Nov 26, 2017 1:44 am
OS or Distro: Ubuntu 16

Linux, Ports, connection

Postby itstooloud » Sun Nov 26, 2017 2:12 am

Hello, I'm trying to set up an old Linux machine to run Sonarr and Deluge together, as described in this tutorial: ... and-deluge. I set it up on a Windows machine with no problems but I'd rather have it running on an old Linux machine I don't use for anything else.

A few pages before that in the tutorial, it instructs to port-forward the router on 38081 for Deluge, which I already did and it's working in the Windows installation of Deluge. The problem is Deluge doesn't look the same in Windows and I'm really not sure I understand what I'm looking at in Ubuntu. Yesterday the connection manager was connecting with the default settings, where it says


Today that doesn't connect and I don't know how to fix it and anyway I don't think it should look like that. In Windows, the above tutorial instructs to select the WebUI option under Plugins, and in Windows, that opens a sub-menu on the left where you can click it and change the LISTENING PORT to 38081. Is this the same port listed in the Connection Manager on Linux? If so, why is the IP address FYI, the router I'm using is and the Linux machine is (not static).

I did notice in the Network Preferences, you can set INCOMING PORTS to FROM .... to ......

Is this the equivalent of the LISTENING PORT on Windows? Should that setting read "FROM 38081 to 38081" ? If so, what's the deal with the odd IP/port in the connection manager?

Are there going to be port conflicts anyway since the Windows installation of Sonarr/Deluge is still running? Do I need to stop that from running to get the Linux one working?

When I google this all I get is a bunch of linux command-line stuff and I don't want to just start typing without understanding what it's doing. Sorry but I'm new to this and usually I can figure this stuff out with enough diligence. I got a Raspberry Pi running Sonarr but couldn't figure out how to give the RPI permission to write to a NAS drive. That's what led me to Ubuntu

Any help would be appreciated!


Posts: 22
Joined: Fri Jan 19, 2018 6:31 pm
OS or Distro: raspbian

Re: Linux, Ports, connection

Postby boomclick » Fri Jan 19, 2018 7:08 pm is the loopback address for the machine you're using. it runs a daemon, deluged, in the background. it connects to the daemon on port 58846 to give you the deluged UI. I would try incoming ports 38081 to 38081 in network preferences. i recommend NFS to give your pi write permission to the NAS. I use NFS and deluge on my pi, it's good for something running in the background.

Return to “Support”

Who is online

Users browsing this forum: Google [Bot] and 29 guests