Proxy settings aren't working

General support for problems installing or using Deluge
New User
New User
Posts: 3
Joined: Wed Jul 16, 2014 4:08 am
OS or Distro: Ubuntu Server 14.04

Proxy settings aren't working

Postby TeenieBopper » Thu Oct 26, 2017 10:13 pm


I'm using Deluge 1.3.12 on an ubuntu server 16.04. I access deluge through the webui. I use Private Internet Access proxy service and my account is in good standing. Looking at other threads/google, I believe my settings to be correct.


However, when I check my torrent IP using and ipmagnet, it says my torrent IP and the IP from my web browser are the same. Would the fact that I'm accessing my server remotely through the webui cause the two IP addresses to match and I have nothing to worry about?

I also tried using the proxy settings for the Web Speed, Tracker, and DHT settings. When I did that, I would get no response from torguard or ipmagnet so I don't know if the proxy is working correctly.

Are my settings correct and it should be working correctly? How can I know for sure?

EDIT: So this is definitely a Deluge problem. I don't have this issue on my desktop version of qbittorrent, but when I tried my desktop version of Deluge, the same thing happened.

Top Bloke
Top Bloke
Posts: 3474
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Proxy settings aren't working

Postby Cas » Fri Oct 27, 2017 6:00 am

Return to “Support”

Who is online

Users browsing this forum: No registered users and 6 guests