Web UI can't change download speeds

General support for problems installing or using Deluge
New User
New User
Posts: 1
Joined: Tue May 30, 2017 12:26 pm
OS or Distro: Ubuntu

Web UI can't change download speeds

Postby chroer » Tue May 30, 2017 12:45 pm


I installed Deluged with the Web UI on my Raspbian Pi 3 Model B (running Ubuntu Mate, but also tried with Raspbian Lite). Now here's my problem: after I did a fresh install of Deluge everything worked fine, but after a reboot the webinterface did not let me change the global download speed (per torrent works fine). I also tried the scheduler, but it did not work either. For the autostart I used the systemd guide in the support section.

Thank You!

Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Web UI can't change download speeds

Postby paulto » Thu Jun 15, 2017 7:29 pm

I had the same issue when I tried the same. I had an old install of deluge running on ubuntu that I hadn't updated in a long time that was running fine. I bought a Pi3 and built it into a seed box to replace my old one and found that it started having issues. I would make changes to the settings and they would not be shown though they were in the webui, remote connected deluge client and config files. I built a new ubuntu based seed box with deluge and it had the same issue. I decided to disconnect from the webui in the connection manager to see if the display wasn't refreshing or it was reading from a cache. When I reconnected the download speed limit was now showing what I had changed it to. I then reset it to unlimited and again the number displayed did not change. I reconnected and the limit was set to unlimited. It is probably just some bug in how it displays the limit. Give it a try and see if the same applies to your build.

If you are using systemd to control the client and are seeding through a vpn or using mounted storage I'd recommend adding a BindsTo= in your unit file to force deluge to close when the vpn fails. Something like :

After=network-online.target openvpn@vpnconffilename.service mnt-freenas-torrents.mount
BindsTo=mnt-freenas-torrents.mount openvpn@vpnconffilename.service

The after makes deluge start after my storage is mounted and openvpn client has started. I bind to my storage mount so I don't start writing to the local disk if the remote storage goes offline and also bind to my openvpn client so if my vpn fails it will prevent me transferring over an unencrypted network connection. Doesn't auto correct but protects against trouble.

Return to “Support”

Who is online

Users browsing this forum: Google [Bot] and 1 guest