Updating Libtorrent because of Error: short read

General support for problems installing or using Deluge
raspdealer
Leecher
Leecher
Posts: 55
Joined: Sun Oct 04, 2015 6:11 pm
OS or Distro: Raspbian

Re: Updating Libtorrent because of Error: short read

Postby raspdealer » Mon Dec 11, 2017 6:22 pm

Yes I followed everything like before. With a 2048 M swap mounted... very weird.
What is the ppa? how to know if my swap is used?
Thanks!

shamael
Super Seeder
Super Seeder
Posts: 362
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updating Libtorrent because of Error: short read

Postby shamael » Tue Dec 12, 2017 8:28 am

The PPA is a Ubuntu repository usable on Debian, no need to compile anymore just add the repo and install.
If you are based on Raspian Jessie, check the "Deluge Launchpad PPA section" of http://dev.deluge-torrent.org/wiki/Inst ... ian/Jessie
For Raspian Stretch the wiki is not updated yet but you can rely on the steps of my post viewtopic.php?f=7&t=54783

raspdealer
Leecher
Leecher
Posts: 55
Joined: Sun Oct 04, 2015 6:11 pm
OS or Distro: Raspbian

Re: Updating Libtorrent because of Error: short read

Postby raspdealer » Tue Dec 12, 2017 6:05 pm

OK clear.
I have installed deluged by buulding the sources directly.
If I only apt-get upgrade -t trusty libtorrent-rasterbar8 python-libtorrent it will work and stay compatible?

shamael
Super Seeder
Super Seeder
Posts: 362
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updating Libtorrent because of Error: short read

Postby shamael » Wed Dec 13, 2017 11:23 am

I did it the same way in the past, not aware about the easy way of the PPA.

It should yes. And if you wanna try, you can remove any deluge/libtorrent package and start from scratch with the PPA. The next time you will be more confident about it ;).

(always keep your .config/deluge safe somewhere else, whatever your try)

raspdealer
Leecher
Leecher
Posts: 55
Joined: Sun Oct 04, 2015 6:11 pm
OS or Distro: Raspbian

Re: Updating Libtorrent because of Error: short read

Postby raspdealer » Wed Jan 10, 2018 7:06 pm

Thanks it updated it correcly.
But now I have all my torrents in status error, how can I revert that?

shamael
Super Seeder
Super Seeder
Posts: 362
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updating Libtorrent because of Error: short read

Postby shamael » Thu Jan 11, 2018 8:42 am

No permission issue? (try a new torrent download to the same location, ubuntu release for example for a free safe torrent)
A force recheck solves it?


Return to “Support”

Who is online

Users browsing this forum: No registered users and 16 guests