Updating Libtorrent because of Error: short read

General support for problems installing or using Deluge
raspdealer
Leecher
Leecher
Posts: 55
Joined: Sun Oct 04, 2015 6:11 pm
OS or Distro: Raspbian

Re: Updating Libtorrent because of Error: short read

Postby raspdealer » Sun Oct 23, 2016 5:02 pm

No permission issue.
pi@deluge ~ $ ls /usr/lib/arm-linux-gnueabihf|grep libboost
libboost_atomic.so.1.55.0

Code: Select all

libboost_filesystem.so.1.55.0
libboost_iostreams.so.1.55.0
libboost_program_options.so.1.55.0
libboost_python-py27.so.1.55.0
libboost_python-py34.so.1.55.0
libboost_regex.so.1.55.0
libboost_system.so.1.55.0
libboost_thread.so.1.55.0


But something weird just happend.

I've launched

Code: Select all

sudo apt-get update && sudo apt-get upgrade && sudo apt-get autoremove && sudo apt-get clean
sudo dpkg -r libtorrent-rasterbar
sudo dpkg -p libtorrent-rasterbar
sudo apt-get update && sudo apt-get upgrade && sudo apt-get autoremove && sudo apt-get clean

to remove your package and after that... libtorrent seems updated...

~ $ deluge -v

Code: Select all

deluge: 1.3.13
libtorrent: 0.16.18.0


now I can focus on the make config issue..
Last edited by raspdealer on Mon Oct 24, 2016 4:31 pm, edited 1 time in total.

shamael
Super Seeder
Super Seeder
Posts: 362
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updating Libtorrent because of Error: short read

Postby shamael » Sun Oct 23, 2016 6:37 pm

It seems you're back on the repository libtorrent version, never removed from your system (as on mine). No deb reinstall test?
Firstly it failed because of libboost but now I guess it should work

Did you check the libboost version needed for libtorrent 1.0.10? If the expected version is above the 1.55 found inb the directory it could be the issue
On mine python 2.7/libboost 1.55/libtorrent 1.0.9 is fine

raspdealer
Leecher
Leecher
Posts: 55
Joined: Sun Oct 04, 2015 6:11 pm
OS or Distro: Raspbian

Re: Updating Libtorrent because of Error: short read

Postby raspdealer » Sun Oct 23, 2016 6:53 pm

Actually, I don't know. I was in version 0.15.smthg before and my plan was to move to 0.16.18...
Now it's done but I didn't succeed in compilation and I've installed yours and removed it... it doesn't sounds logic to me...

To come back to the configure issue, I ran the configure command within 1.0.9 folder just downloaded -> result with same error
Any thoughts?

Thanks

shamael
Super Seeder
Super Seeder
Posts: 362
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updating Libtorrent because of Error: short read

Postby shamael » Sun Oct 23, 2016 9:05 pm

You made "sudo apt-get upgrade" and the default actual Debian libtorrent version is 0.16.18 so It's the explanation.

See the content of the command below on my system. Do you have them all?

sudo dpkg -l|grep libboost*
ii libboost-python-dev 1.55.0.2 armhf Boost.Python Library development files (default version)
ii libboost-python1.55-dev 1.55.0+dfsg-3 armhf Boost.Python Library development files
ii libboost-python1.55.0 1.55.0+dfsg-3 armhf Boost.Python Library
ii libboost-system-dev:armhf 1.55.0.2 armhf Operating system (e.g. diagnostics support) library (default version)
ii libboost-system1.55-dev:armhf 1.55.0+dfsg-3 armhf Operating system (e.g. diagnostics support) library
ii libboost-system1.55.0:armhf 1.55.0+dfsg-3 armhf Operating system (e.g. diagnostics support) library
ii libboost1.55-dev:armhf 1.55.0+dfsg-3 armhf Boost C++ Libraries development files

raspdealer
Leecher
Leecher
Posts: 55
Joined: Sun Oct 04, 2015 6:11 pm
OS or Distro: Raspbian

Re: Updating Libtorrent because of Error: short read

Postby raspdealer » Mon Oct 24, 2016 4:35 pm

For this command, I have less things than you...
pi@deluge ~ $ ls /usr/lib/arm-linux-gnueabihf|grep libboost

Are missing:

Code: Select all

libboost_python.a
libboost_python-py27.a
libboost_python-py27.so
libboost_python-py34.a
libboost_python-py34.so
libboost_python.so
libboost_system.a
libboost_system.so


Full result:

Code: Select all

libboost_atomic.so.1.55.0
libboost_filesystem.so.1.55.0
libboost_iostreams.so.1.55.0
libboost_program_options.so.1.55.0
libboost_python-py27.so.1.55.0
libboost_python-py34.so.1.55.0
libboost_regex.so.1.55.0
libboost_system.so.1.55.0
libboost_thread.so.1.55.0

shamael
Super Seeder
Super Seeder
Posts: 362
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updating Libtorrent because of Error: short read

Postby shamael » Mon Oct 24, 2016 6:34 pm

have you launched this command after the dist-upgrade to Jessie ? If not try

Code: Select all

sudo apt-get install build-essential checkinstall libboost-system-dev libboost-python-dev libssl-dev libgeoip-dev

shamael
Super Seeder
Super Seeder
Posts: 362
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updating Libtorrent because of Error: short read

Postby shamael » Mon Oct 24, 2016 6:43 pm

checking some packet content and for example

/usr/lib/arm-linux-gnueabihf/libboost_python.a
/usr/lib/arm-linux-gnueabihf/libboost_python.so
/usr/lib/arm-linux-gnueabihf/libboost_python-py27.so
/usr/lib/arm-linux-gnueabihf/libboost_python-py34.so

Are part of libboost-python1.55-dev

raspdealer
Leecher
Leecher
Posts: 55
Joined: Sun Oct 04, 2015 6:11 pm
OS or Distro: Raspbian

Re: Updating Libtorrent because of Error: short read

Postby raspdealer » Mon Oct 24, 2016 7:44 pm

Sounds like a good idea! I will restart everything properly now I moved to jessie...

raspdealer
Leecher
Leecher
Posts: 55
Joined: Sun Oct 04, 2015 6:11 pm
OS or Distro: Raspbian

Re: Updating Libtorrent because of Error: short read

Postby raspdealer » Tue Oct 25, 2016 5:50 pm

Config passed successfully.
Make in progress.
Faster and with less warnings.

Thanks :D

shamael
Super Seeder
Super Seeder
Posts: 362
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updating Libtorrent because of Error: short read

Postby shamael » Tue Oct 25, 2016 7:29 pm

Happy to read this message ;). Keep me posted


Return to “Support”

Who is online

Users browsing this forum: No registered users and 16 guests