[SOLVED][deluge-web] Forcing/Enabling TLS (Ubuntu 14.04.2)

General support for problems installing or using Deluge
ClontarfX

[SOLVED][deluge-web] Forcing/Enabling TLS (Ubuntu 14.04.2)

Postby ClontarfX » Tue Mar 03, 2015 2:11 pm

[SOLUTION:] Update your APT repositories using the instructions at http://dev.deluge-torrent.org/wiki/Inst ... Repository
Make sure you do an apt-get update and apt-get upgrade deluged deluge-web
My installation is now using TLS and I can use certificates to connect to my deluge-web server once more :)

------------------------------------------------

Hi All,

As some may know, recently browser have stopped supporting SSLv3 due to various security flaws discovered. By default, these browsers will reject requests to SSLv3-enabled web servers. SSL in general has been ditched in favour of TLS, the "successor" to the SSL standard. From what I can tell, the Web UI-serving application that deluge-web uses is using SSLv2, and does not use (or support) TLS.

Ubuntu 14.04.2 LTS \n \l -- Deluge 1.3.6 OOB
A secure connection cannot be established because this site uses an unsupported protocol.
Error code: ERR_SSL_VERSION_OR_CIPHER_MISMATCH

~/.config/deluge/ssl$ certtool -i --infile daemon.cert
X.509 Certificate Information:
Version: 1

Does anyone know if there is a way to make TLS the default protocol for deluge-web? Currently I cannot use any self-signed certificate because of this recent browser decision to remove SSL support in favour of TLS.

*edit* Just read that 1.3.10 switches to TLS. It's a shame the Ubuntu LTS still only has 1.3.6.

Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests