compiling problems

General support for problems installing or using Deluge
econobeing
New User
New User
Posts: 4
Joined: Thu Jun 07, 2007 9:02 pm
Location: Tacoma, WA
Contact:

compiling problems

Postby econobeing » Thu Jun 07, 2007 9:36 pm

i get the same error with the 0.5.1 beta2 and the svn version. i made sure to have all the dependencies listed in the readme before trying to compile, using synaptic and apt-get to make doubly sure <_<

Code: Select all

econobeing@lappy:~/programs/deluge/deluge$ python setup.py build
Attempting to detect your system information
32bit x86 system detected
Linux operating system detected
Libraries nomt
running build
running build_py
running build_ext
building 'deluge_core' extension
gcc -pthread -fno-strict-aliasing -Wall -DNDEBUG -O2 -fPIC -I./libtorrent -I./libtorrent/include -I./libtorrent/include/libtorrent -I/usr/include/python2.5 -I/usr/include/python2.5 -c src/deluge_core.cpp -o build/temp.linux-i686-2.5/src/deluge_core.o -Wno-missing-braces
In file included from src/deluge_core.cpp:41:
./libtorrent/include/libtorrent/hasher.hpp:45:25: error: openssl/sha.h: No such file or directory
./libtorrent/include/libtorrent/hasher.hpp:101: error: ‘SHA_CTX’ does not name a type
./libtorrent/include/libtorrent/hasher.hpp: In constructor ‘libtorrent::hasher::hasher()’:
./libtorrent/include/libtorrent/hasher.hpp:75: error: ‘m_context’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp:75: error: ‘SHA1_Init’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp: In constructor ‘libtorrent::hasher::hasher(const char*, int)’:
./libtorrent/include/libtorrent/hasher.hpp:78: error: ‘m_context’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp:78: error: ‘SHA1_Init’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp:81: error: ‘SHA1_Update’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp: In member function ‘void libtorrent::hasher::update(const char*, int)’:
./libtorrent/include/libtorrent/hasher.hpp:87: error: ‘m_context’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp:87: error: ‘SHA1_Update’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp: In member function ‘libtorrent::sha1_hash libtorrent::hasher::final()’:
./libtorrent/include/libtorrent/hasher.hpp:93: error: ‘m_context’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp:93: error: ‘SHA1_Final’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp: In member function ‘void libtorrent::hasher::reset()’:
./libtorrent/include/libtorrent/hasher.hpp:97: error: ‘m_context’ was not declared in this scope
./libtorrent/include/libtorrent/hasher.hpp:97: error: ‘SHA1_Init’ was not declared in this scope
error: command 'gcc' failed with exit status 1

User avatar
irfan
Leecher
Leecher
Posts: 70
Joined: Sun Jun 03, 2007 5:36 pm
Location: Poland

Re: compiling problems

Postby irfan » Thu Jun 07, 2007 10:11 pm

you need to install libssl-dev

markybob
Compulsive Poster
Compulsive Poster
Posts: 1230
Joined: Thu May 24, 2007 11:27 pm
Location: Chicago, IL, USA
Contact:

Re: compiling problems

Postby markybob » Thu Jun 07, 2007 10:29 pm

econobeing wrote:i get the same error with the 0.5.1 beta2 and the svn version. i made sure to have all the dependencies listed in the readme before trying to compile, using synaptic and apt-get to make doubly sure <_<

yeah, sorry, i'll update the readme to specify libssl-dev as well. thanks

econobeing
New User
New User
Posts: 4
Joined: Thu Jun 07, 2007 9:02 pm
Location: Tacoma, WA
Contact:

Re: compiling problems

Postby econobeing » Fri Jun 08, 2007 12:09 am

ah, that did the trick, thanks much!


Return to “Support”

Who is online

Users browsing this forum: No registered users and 12 guests