New Install cannot associate magnet links to Deluge

General support for problems installing or using Deluge
User avatar
AraiBob
New User
New User
Posts: 7
Joined: Mon Aug 18, 2014 8:13 am
OS or Distro: Ubuntu

New Install cannot associate magnet links to Deluge

Postby AraiBob » Sat Aug 23, 2014 6:06 am

I installed Ubuntu 14.04.1 including Deluge. This was NOT an upgrade, but a fresh install.

I am having some odd issues.

Most important is when I click on the magnet link in Firefox, what comes up is expecting Transmission, not Deluge.

I have tried clicking the button in Preferences / Other which is to make the association of magnet links to Deluge, and it does not work.


I did some searches of the support forum and found this has been an issue, but all are older versions. What went wrong with the install? and how to fix?

Spadge
Seeder
Seeder
Posts: 111
Joined: Sat Dec 13, 2008 4:17 pm

Re: New Install cannot associate magnet links to Deluge

Postby Spadge » Sun Aug 24, 2014 1:20 am

I think it depends on your desktop environment.

I use KDE and had to make my own magnet handler:

Code: Select all

cat ~/.kde/share/kde4/services/magnet.protocol
[Protocol]
exec=deluge-gtk "%U"
protocol=magnet
input=none
output=none
helper=true
listing=false
reading=false
writing=false
makedir=false
deleting=false


This might help you: http://www.pclinuxos.com/forum/index.php?topic=103267.0

Cas
Top Bloke
Top Bloke
Posts: 3557
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: New Install cannot associate magnet links to Deluge

Postby Cas » Sun Aug 24, 2014 8:32 am

There are many answers on AskUbuntu so you need to search better. Likely this is the solution:

Code: Select all

xdg-mime default deluge.desktop x-scheme-handler/magnet


If not start with this question and go from there.

Edit: The associate magnet code might be a bit old now so create a ticket and we'll look to update to use mime scheme.

User avatar
AraiBob
New User
New User
Posts: 7
Joined: Mon Aug 18, 2014 8:13 am
OS or Distro: Ubuntu

Re: New Install cannot associate magnet links to Deluge

Postby AraiBob » Mon Aug 25, 2014 5:07 am

All,

I found an answer, though it puzzled me when I read it.

I was attempting to get Ubuntu Linux to 'connect' Magnet links to Deluge. It does have a link to Transmission, which is installed as a default. There is a 'way' to connect to Deluge and disconnect from Transmission, by pointing the connection to the program Deluge. Unfortunately, I was not sure exactly where the program resides.

The fix I did was to tell Firefox to make the connection. This was done easily and worked the first time.

Best regards

davidm
New User
New User
Posts: 5
Joined: Mon Aug 25, 2014 2:59 am
OS or Distro: Arch Linux

Re: New Install cannot associate magnet links to Deluge

Postby davidm » Mon Aug 25, 2014 3:43 pm

AraiBob wrote:Unfortunately, I was not sure exactly where the program resides.


Hi AraiBob. Just to help you in the future usually you can do:

Code: Select all

which deluge


or

Code: Select all

whereis deluge


at a terminal to figure out the location. Where <deluge> can be any program name. See 'man which' for more info. :)

Debra743
New User
New User
Posts: 1
Joined: Tue Dec 25, 2018 11:59 am
OS or Distro: OS

Re: New Install cannot associate magnet links to Deluge

Postby Debra743 » Wed Dec 26, 2018 9:28 am

Then I 'manually' started qBittorrent and closed it again. The next time I clicked a magnet link I was prompted by Chrome to allow it to call an external application LiteBlue. I allowed this and chrome then fired up qBitorrent.

So it seems that if you don't need to have more than one torrent client on your PC, by removing the others and leaving the one you want, you can force Chrome to use the desired client. A bit of a Chuck Norris solution, but it worked for me.
Last edited by Debra743 on Sat Jan 12, 2019 5:39 am, edited 2 times in total.

alex989
New User
New User
Posts: 1
Joined: Thu Nov 15, 2018 12:22 pm
OS or Distro: OS

Re: New Install cannot associate magnet links to Deluge

Postby alex989 » Tue Jan 01, 2019 11:08 am

I recently had the same issue after installing u_torrent. I need 2 torrent programs because of private trackers that do not allow DHT.
U_torrent associated itself with magnet links which I didn't want it to do and the button in the deluge settings doesn't actually do anything.
I scoured the internet for about an hour trying to find a solution because the link in this post is dead. MYBKExperience
Last edited by alex989 on Thu Jan 03, 2019 4:14 am, edited 1 time in total.

Spadge
Seeder
Seeder
Posts: 111
Joined: Sat Dec 13, 2008 4:17 pm

Re: New Install cannot associate magnet links to Deluge

Postby Spadge » Wed Jan 02, 2019 7:36 pm

alex989 wrote:I recently had the same issue after installing u_torrent. I need 2 torrent programs because of private trackers that do not allow DHT.
U_torrent associated itself with magnet links which I didn't want it to do and the button in the deluge settings doesn't actually do anything.
I scoured the internet for about an hour trying to find a solution because the link in this post is dead.


What Operating System (Desktop Environment if a Linux or UNIX) and Browser are you using?


Return to “Support”

Who is online

Users browsing this forum: No registered users and 6 guests