Deluge webui is not watching Auto-Download folder

General support for problems installing or using Deluge
hypnotoad
New User
New User
Posts: 4
Joined: Fri Jun 14, 2013 10:27 pm

Deluge webui is not watching Auto-Download folder

Postby hypnotoad » Sat Jun 15, 2013 2:41 am

I am running deluge/deluged/deluge-web using a startup script on Ubuntu 13.04
Permissions to folder

Code: Select all

drwxr-xr-x  12 root   root   4096 May 28 21:21 home
drwxrwxrwx+ 21 torrent  torrents  4096 Jun 14 22:04 torrent
getfacl home/torrent/
# file: home/torrent/
# owner: torrent
# group: torrents
user::rwx
user:deluge:rwx
group::rwx
group:deluge:rwx
mask::rwx
other::rwx

drwxrwxrwt+ 3 torrent torrents  4096 Jun 14 22:27 Downloads
/home/torrent$ getfacl Downloads/
# file: Downloads/
# owner: torrent
# group: torrents
# flags: --t
user::rwx
user:deluge:rwx
group::rwx
group:deluge:rwx
mask::rwx
other::rwx
default:user::rwx
default:group::rwx
default:mask::rwx
default:other::rwx

-rw-rw-rw-+ 1 torrent users 349262 Jun 14 22:40 Fedora-18-x86_64-DVD.torrent
getfacl Fedora-18-x86_64-DVD.torrent
# file: Fedora-18-x86_64-DVD.torrent
# owner: torrent
# group: users
user::rw-
group::rwx                      #effective:rw-
mask::rw-
other::rw-




I would think that would be the correct user permissions, so I checked my config files in /var/lib/deluge/:

audoadd.conf

Code: Select all

home/torrent$ sudo cat /var/lib/deluge/.config/deluge/autoadd.conf
{
  "file": 1,
  "format": 1
}{
  "watchdirs": {
    "1": {
      "path": "/home/torrent/Downloads",
      "abspath": "/home/torrent/Downloads",
      "enabled": false
    }
  },
  "next_id": 2


You will notice the above says "enabled": false , so I switched it to true, and restarted deluged, however, deluge is still not adding torrents once they are downloaded.

web.conf

Code: Select all

sudo cat /var/lib/deluge/.config/deluge/web.conf
{
  "file": 1,
  "format": 1
}{
  "port": 8112,
  "enabled_plugins": [],
  "pwd_sha1": "omit",
  "theme": "gray",
  "show_sidebar": true,
  "sidebar_show_zero": false,
  "pkey": "ssl/daemon.pkey",
  "https": false,
  "sessions": {
    "omit": {
      "login": "admin",
      "expires": 1371267047.0,
      "level": 10
    }
  },
  "base": "/",
  "pwd_salt": "omit",
  "show_session_speed": true,
  "first_login": false,
  "cert": "ssl/daemon.cert",
  "session_timeout": 3600,
  "default_daemon": "",
  "sidebar_multiple_filters": true
}


core.conf

Code: Select all

sudo cat /var/lib/deluge/.config/deluge/core.conf
{
  "file": 1,
  "format": 1
}{
  "info_sent": 0.0,
  "lsd": true,
  "send_info": false,
  "move_completed_path": "/var/lib/deluge",
  "enc_in_policy": 1,
  "queue_new_to_top": false,
  "ignore_limits_on_local_network": true,
  "rate_limit_ip_overhead": true,
  "daemon_port": 58846,
  "natpmp": true,
  "max_active_limit": 25,
  "utpex": true,
  "max_active_downloading": 10,
  "max_active_seeding": 15,
  "allow_remote": false,
  "max_half_open_connections": 50,
  "download_location": "/srv/torrent",
  "compact_allocation": true,
  "max_upload_speed": -1.0,
  "cache_expiry": 60,
  "prioritize_first_last_pieces": false,
  "auto_managed": true,
  "enc_level": 2,
  "max_connections_per_second": 20,
  "dont_count_slow_torrents": false,
  "random_outgoing_ports": true,
  "max_upload_slots_per_torrent": -1,
  "new_release_check": true,
  "enc_out_policy": 1,
  "outgoing_ports": [
    55995,
    56000
  ],
  "seed_time_limit": 180,
  "cache_size": 512,
  "share_ratio_limit": 2.0,
  "max_download_speed": -1.0,
  "geoip_db_location": "/usr/share/GeoIP/GeoIP.dat",
  "torrentfiles_location": "/var/lib/deluge",
  "stop_seed_at_ratio": true,
  "peer_tos": "0x00",
  "listen_interface": "",
  "upnp": true,
  "max_download_speed_per_torrent": -1,
  "max_upload_slots_global": 4,
  "enabled_plugins": [
    "AutoAdd",
    "Scheduler"
  ],
  "random_port": true,
  "autoadd_enable": true,
  "max_connections_global": 200,
  "enc_prefer_rc4": true,
  "listen_ports": [
    55990,
    55994
  ],
  "dht": true,
  "stop_seed_ratio": 5.0,
  "seed_time_ratio_limit": 7.0,
  "max_upload_speed_per_torrent": -1,
  "copy_torrent_file": false,
  "del_copy_torrent_file": false,
  "move_completed": false,
  "proxies": {
    "peer": {
      "username": "",
      "password": "",
      "type": 0,
      "hostname": "",
      "port": 8080
    },
    "web_seed": {
      "username": "",
      "password": "",
      "type": 0,
      "hostname": "",
      "port": 8080
    },
    "tracker": {
      "username": "",
      "password": "",
      "type": 0,
      "hostname": "",
      "port": 8080
    },
    "dht": {
      "username": "",
      "password": "",
      "type": 0,
      "hostname": "",
      "port": 8080
    }
  },
  "add_paused": false,
  "max_connections_per_torrent": -1,
  "remove_seed_at_ratio": false,
  "autoadd_location": "/home/torrent/Downloads",
  "plugins_location": "/var/lib/deluge/.config/deluge/plugins"


If I look at the log files for deluge-daemon, I see:
/var/log/deluge/daemon.log

Code: Select all

[ERROR   ] 22:30:54 core:323 Disabling '/home/torrent/Downloads', error during update: [Failure instance: Traceback: <type 'exceptions.OSError'>: [Errno 1] Operation not permitted: '/home/torrent/Downloads/Fedora-18-x86_64-DVD.torrent'
/usr/lib/python2.7/dist-packages/deluge/plugins/AutoAdd-1.04.egg/autoadd/core.py:120:enable_looping
/usr/lib/python2.7/dist-packages/deluge/plugins/AutoAdd-1.04.egg/autoadd/core.py:331:enable_watchdir
/usr/lib/python2.7/dist-packages/twisted/internet/task.py:173:start
/usr/lib/python2.7/dist-packages/twisted/internet/task.py:218:__call__
--- <exception caught here> ---
/usr/lib/python2.7/dist-packages/twisted/internet/defer.py:138:maybeDeferred
/usr/lib/python2.7/dist-packages/deluge/plugins/AutoAdd-1.04.egg/autoadd/core.py:318:update_watchdir
]

/var/log/deluge/web.log

Code: Select all

[WARNING ] 22:30:49 config:361 Unable to open config file /var/lib/deluge/.config/deluge/hostlist.conf.1.2: [Errno 2] No such file or directory: '/var/lib/deluge/.config/deluge/hostlist.conf.1.2'


/var/lib/deluge/.config/deluge/plugins

Code: Select all

sudo ls -al /var/lib/deluge/.config/deluge/plugins
total 8
drwxrwx--- 2 deluge deluge 4096 Jun 14 17:15 .
drwx------ 6 deluge deluge 4096 Jun 14 22:53 ..




So, I am not sure what the cause is here, but it definitely isn't working. :/ All in all it seems like it isn't listening to the config files. For instance, I set it to open up a specific port range, but, after restarting deluged, it set it back to random. The download location works fine, I can manually add torrents, and they download fine. Just autoadd doesn't work. If I load up the thinclient, set the folder, then disconnect, then reconnect with the thinclient again, the checkbox will be listed, but the folder location will just be a blank square (as can be seen below)
http://i.imgur.com/FFno0kz.png


I think this is all the information I can possibly give you guys, so any help would be awesome. Because at this point, I am left clueless as to why it isn't working.


Tried this over again this morning, followed these guides:
http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient
http://dev.deluge-torrent.org/wiki/User ... t%20Job%29

So my config folders are fresh, and listed under /var/lib/deluge and unfortunately, the same issues are occuring, where folders just show up blank after being set. Core.conf is aware of the changes, but it isn't following the config file.

Cas
Top Bloke
Top Bloke
Posts: 3643
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Deluge webui is not watching Auto-Download folder

Postby Cas » Mon Jun 17, 2013 12:04 am

Are you manually editing the conf files? You can only make changes with deluge shutdown and the autoadd.conf looks badly formatted.

ben2talk
New User
New User
Posts: 9
Joined: Tue Oct 26, 2010 12:06 am

Re: Deluge webui is not watching Auto-Download folder

Postby ben2talk » Fri Sep 13, 2013 12:29 am

Using Linux Mint Mate, I'm seeing the same lack of display of the download folders until I reselect them; although if I do not reselect them, the downloads still go to the previously set folder.


Return to “Support”

Who is online

Users browsing this forum: Baidu [Spider] and 10 guests