Page 1 of 1

Deluge revision 460 quits when download finished

Posted: Sat Jun 02, 2007 1:51 pm
by webaake
Seems that SVN 460 quits unexpectedly just when a torrent is completely downloaded and what was downloaded since the last start of Deluge is forgotten.

So, it might be that is never can finish anything since it crashes at the very last step.


I'm gonna try removing all in :/config/deluge and then just add one almost finished torrent.


I'll report back shortly....
REPORT: removing all in :/config/deluge and then just add one almost finished torrent. - DID WORK! It finally finished att 100% without crashing.

I'm now going to try 0.51 beta instead, the latest SVN doesn't seem to work as it is intended to do.

2 observations;
* There is nothing in the log window inside Deluge
* I can't find any other logs anywhere else either

Re: Deluge revision 460 quits when download finished

Posted: Sat Jun 02, 2007 8:59 pm
by markybob
webaake wrote:Seems that SVN 460 quits unexpectedly just when a torrent is completely downloaded and what was downloaded since the last start of Deluge is forgotten.

So, it might be that is never can finish anything since it crashes at the very last step.


I'm gonna try removing all in :/config/deluge and then just add one almost finished torrent.


I'll report back shortly....
REPORT: removing all in :/config/deluge and then just add one almost finished torrent. - DID WORK! It finally finished att 100% without crashing.

I'm now going to try 0.51 beta instead, the latest SVN doesn't seem to work as it is intended to do.

2 observations;
* There is nothing in the log window inside Deluge
* I can't find any other logs anywhere else either

yeah, i know about this bug. it's a libtorrent bug, actually. if you load up the torrent again, it should check it and seed it. it might crash a couple of times before getting there, but it does get there eventually. sorry, i'm trying to get it fixed.

Re: Deluge revision 460 quits when download finished

Posted: Sun Jun 03, 2007 5:38 pm
by markybob
markybob wrote:yeah, i know about this bug. it's a libtorrent bug, actually. if you load up the torrent again, it should check it and seed it. it might crash a couple of times before getting there, but it does get there eventually. sorry, i'm trying to get it fixed.

i just fixed this in svn 466. enjoy