Fails to start GTK/GUI

General support for problems installing or using Deluge
webaake
Member
Member
Posts: 16
Joined: Wed May 30, 2007 6:58 am

Fails to start GTK/GUI

Postby webaake » Wed May 30, 2007 7:01 am

Hi!

Just compiled Deluge succesfully on Ubuntu 7.04 with all libraries. But when trying to start Deluge from terminal I get this;

/var/lib/python-support/python2.5/gtk-2.0/gtk/__init__.py:69: GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
File "/usr/bin/deluge", line 54, in <module>
bus = dbus.SessionBus()
File "/var/lib/python-support/python2.5/dbus/_dbus.py", line 669, in __new__
mainloop=mainloop)
File "/var/lib/python-support/python2.5/dbus/_dbus.py", line 293, in __new__
mainloop=mainloop)
dbus.DBusException: org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute dbus-launch to autolaunch D-Bus session

What's wrong? Should I enclose some more info?

Regards,

firstime user, sweden

markybob
Compulsive Poster
Compulsive Poster
Posts: 1230
Joined: Thu May 24, 2007 11:27 pm
Location: Chicago, IL, USA
Contact:

Re: Fails to start GTK/GUI

Postby markybob » Wed May 30, 2007 6:03 pm

you werent trying to run as root, were you?

bejelith
New User
New User
Posts: 5
Joined: Tue May 29, 2007 8:02 am
Contact:

Re: Fails to start GTK/GUI

Postby bejelith » Fri Jun 01, 2007 1:48 pm

markybob wrote:you werent trying to run as root, were you?

i started it by root... no problems

dont starting flame! it was just a test...


webaake wrote:/var/lib/python-support/python2.5/gtk-2.0/gtk/__init__.py:69: GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)

do

Code: Select all

echo $DISPLAY

and post the answer
Image

webaake
Member
Member
Posts: 16
Joined: Wed May 30, 2007 6:58 am

Re: Fails to start GTK/GUI

Postby webaake » Fri Jun 01, 2007 7:27 pm

Sorry for the late answer, but a reboot made it visible in the Programs menu (internet apps). So I think a reboot of x-system would have solved the problem.

And no I wasn't root, but sudo. Maybe that was the problem?


cherio,

Ake, Sweden
PS Latest SVN 460 runs superfine!

markybob
Compulsive Poster
Compulsive Poster
Posts: 1230
Joined: Thu May 24, 2007 11:27 pm
Location: Chicago, IL, USA
Contact:

Re: Fails to start GTK/GUI

Postby markybob » Fri Jun 01, 2007 8:22 pm

webaake wrote:Sorry for the late answer, but a reboot made it visible in the Programs menu (internet apps). So I think a reboot of x-system would have solved the problem.

And no I wasn't root, but sudo. Maybe that was the problem?


cherio,

Ake, Sweden
PS Latest SVN 460 runs superfine!

yes, sudo and running as root as pretty much the same thing. you really shouldnt run something like a bittorrent client as root...it's just asking for trouble :) glad you solved your problems


Return to “Support”

Who is online

Users browsing this forum: No registered users and 9 guests