Problem with Jackett & Deluge (Using Black Hole)

General support for problems installing or using Deluge
Post Reply
sailor
New User
New User
Posts: 3
Joined: Tue Jun 22, 2021 12:06 am

Problem with Jackett & Deluge (Using Black Hole)

Post by sailor »

Hello,

I have been using Jackett & Deluge as dockers on my Synology for about a year, and working really great. I use the AutoAdd plugin in Deluge to allow me to do a manual search in Jackett and send the file to the Blackhole folder to be automatically added in Deluge.

Recently though if in Jackett search I press the "Save to server blackhole directory" button, the file is not added. It's saved in the Blackhole folder correctly. And if I try to "add file" in Deluge, and select that Magnet file, it also fails and says "invalid torrent file".

For interest sake I went to https://checker.openwebtorrent.com/ and pasted the text from the magnet file, and it seems fine.

I just don't know if this is a Jackett problem, or Deluge, or something totally different.

Deluge Version - 2.0.4.dev56 Jackett Version - 0.18.367

Can anyone help point me in the right direction?
mhertz
Moderator
Moderator
Posts: 1188
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Problem with Jackett & Deluge (Using Black Hole)

Post by mhertz »

You cannot test with adding a .magnet file to deluge, as this isn't supported and is a feature of the autoadd plugin only i.e. magnets in files. You could open the text file and copy the link and paste into deluge as url to see if will work though.

Anyway, I know nothing about jacket and whatnot, but I did see there where a commit a month or so ago by Cas regarding autoadd plugin and magnets. It should fix a bug, but now in my testing it makes it worse i.e. after one magnet added it disabled the watchfolder internally, so no other magnets added untill next restart. If reverting that commit, then works again, but has the error Cas mentioned in commit-log i.e. .magnet file gets renamed invalid and isn't labeled, but atleast is added to the session in my tests.

If you wanna have old functionality back, as sorry I don't know how to fix new problem, or old, but can atleast rebuild plugin with said commit revoked, and since you're on docker, then from past experience I know upping version number or changing name isn't enough there, and needs changing both directory-name, entry-points and _pkg_data of setup.py, and then finally doesn't overlap with old plugin files. I did up the version also, to know it's the new one when selecting it in preferences and seeing the version number.

Drop it in your deluge profile's plugins dir and restart deluge, and it will be used in place of original plugin.

Btw, I seem to remember the previous synology user I talked with here, was using python2 deluge, though that was 2.0.3, and maybe not docker, don't know much about this honestly, but just in case I also rebuilt a py2.7 version for deluge2.

AutoAdd-1.9-py3.9.egg

AutoAdd-1.9-py2.7.egg
sailor
New User
New User
Posts: 3
Joined: Tue Jun 22, 2021 12:06 am

Re: Problem with Jackett & Deluge (Using Black Hole)

Post by sailor »

mhertz wrote: Tue Jun 22, 2021 7:42 pm You cannot test with adding a .magnet file to deluge, as this isn't supported and is a feature of the autoadd plugin only i.e. magnets in files. You could open the text file and copy the link and paste into deluge as url to see if will work though.

Anyway, I know nothing about jacket and whatnot, but I did see there where a commit a month or so ago by Cas regarding autoadd plugin and magnets. It should fix a bug, but now in my testing it makes it worse i.e. after one magnet added it disabled the watchfolder internally, so no other magnets added untill next restart. If reverting that commit, then works again, but has the error Cas mentioned in commit-log i.e. .magnet file gets renamed invalid and isn't labeled, but atleast is added to the session in my tests.

If you wanna have old functionality back, as sorry I don't know how to fix new problem, or old, but can atleast rebuild plugin with said commit revoked, and since you're on docker, then from past experience I know upping version number or changing name isn't enough there, and needs changing both directory-name, entry-points and _pkg_data of setup.py, and then finally doesn't overlap with old plugin files. I did up the version also, to know it's the new one when selecting it in preferences and seeing the version number.

Drop it in your deluge profile's plugins dir and restart deluge, and it will be used in place of original plugin.

Btw, I seem to remember the previous synology user I talked with here, was using python2 deluge, though that was 2.0.3, and maybe not docker, don't know much about this honestly, but just in case I also rebuilt a py2.7 version for deluge2.

AutoAdd-1.9-py3.9.egg

AutoAdd-1.9-py2.7.egg
Thanks for the reply! I had posted in Reddit as well and did get another response that further points to a problem with a recent version. Reddit user stated he reverted back to 2.0.3-2-01 and I have done the same, and resolved the problem. We're both using Docker in Synology.
sailor
New User
New User
Posts: 3
Joined: Tue Jun 22, 2021 12:06 am

Re: Problem with Jackett & Deluge (Using Black Hole)

Post by sailor »

Sorry...I am really not sure what was wrong with my question, or why it shouldn't have been allowed to be posted. I'm not a genius. Sorry.
mhertz
Moderator
Moderator
Posts: 1188
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Problem with Jackett & Deluge (Using Black Hole)

Post by mhertz »

I sincerly apologise sailor for the confusion and none whatsoever directed at your posting which had nothing in the slightest wrong with it :)

We just have lately been overflooded by spam bots, which quote a post, sometimes many years old even, and add one of the lines of previous replies afterwards, or otherwise auto-generated generic response, and theninsert a spam link inside the quoting, presumably to get around restrictions on posting actual links directly. For instance if you google the user above, watson and name of the website url embeeded into my quote, 'stickman hook', then several results come up from other places from this watson, rose watson or nick watson etc, with a dumbass generated remark and the stupid link preceeding.

Again i'm sorry mate, and should have clarified better what I was talking about, and feel bad you thought it was directed at you, but my bad, and just got little pissed off at the moment there, woke up in the wrong side of the bed or whatever called, or if even makes sence in other languages than mine lol :)

Cheers.

Edit: Okay now I even more understand your confusion, as I had reported the spam post and so got deleted and now my posting right after yours doh! :) Also generally one should never respond to spam or trolling etc and just report, which I ussually also would adhere to, but as said, was just on the grumpy side that morning or something. Sorry again mate!
Post Reply