Autorunning on Debian

General support for problems installing or using Deluge
creative-2008
New User
New User
Posts: 5
Joined: Tue Mar 13, 2018 8:58 pm
OS or Distro: Debian

Autorunning on Debian

Postby creative-2008 » Tue Mar 13, 2018 9:05 pm

I have Raspbian (Debian) running on my Raspberry Pi, and used the guide below to get Deluge up and running.

I'm successfully running the web UI and am able to connect to it when on the same LAN from a remote browser.

https://www.howtogeek.com/142044/how-to ... rrent-box/

However, each time the Raspberry Pi is restart I need to run 'deluge-web' and 'deluged' from the command line to get them to boot. Otherwise, nothing happens. The steps at the bottom of that guide haven't made any difference.

'deluge-web' runs fine when launched manually, but 'deluged' throws up the same error consistently. Could this be related? If so, I can post screenshots.

creative-2008
New User
New User
Posts: 5
Joined: Tue Mar 13, 2018 8:58 pm
OS or Distro: Debian

Re: Autorunning on Debian

Postby creative-2008 » Tue Mar 13, 2018 9:12 pm

Decided it made sense to screenshot regardless.

Image

shamael
Super Seeder
Super Seeder
Posts: 401
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Autorunning on Debian

Postby shamael » Wed Mar 14, 2018 10:07 am

Hi,

Please check the wiki for systemd services you need to create.
https://dev.deluge-torrent.org/wiki/Use ... ce/systemd


Return to “Support”

Who is online

Users browsing this forum: gw1500se and 5 guests