Page 1 of 1

Insufficient rights for saving file

Posted: Wed Jun 05, 2019 7:24 am
by Tockman
Deluge 1.3.15, MacOS 10.15.
I tried to move downloaded file on external disk and got an error: "Could not read the contents of My Book Thunderbolt Duo. Error opening directory '/Volumes/My Book Thunderbolt Duo': Operation not permitted".
The same thing goes when I wanted to save it in a desktop folder. I guess the access rights are problem. Is there some working solution? If so, what I need to add to folder properties?

Re: Insufficient rights for saving file

Posted: Fri Jun 07, 2019 1:36 pm
by shamael

Adapt the permission for the folder used by Deluge and all subfolder/files to the user Deluge is loading with.
I'm not a Mac user as permissions are based on Linux it should e the same stuff

Re: Insufficient rights for saving file

Posted: Sat Jun 08, 2019 1:44 am
by fuga
Whenever I've run into this simply rebooting fixes permissions.

Re: Insufficient rights for saving file

Posted: Sat Oct 12, 2019 10:19 pm
by keca2360
I am having this issue as well. MacOS 10.15, Deluge 1.3.15

I am using a torrent from a private tracker. When attempting to open the torrent file, Deluge gives the above error when attempting to browse to the containing folder. This is remedied by saving the torrent file to Google Drive and opening it from there.

Curious that Deluge seems to have no problem with saving the file to the same folder that it does not have permission to browse...

I have tried all of the obvious remedies, but 'simply rebooting fixes permissions' doesn't make much sense to me, not to mention failing to fix the issue.

It seems the whole world is having trouble with torrent files and Catalina. For now, saving the torrent to a cloud drive seems to be a decent workaround, albeit annoying.

Re: Insufficient rights for saving file

Posted: Sat Oct 19, 2019 11:08 pm
by ania1224
I am having this same issue since MacOS updated recently. Gave Deluge full access in sys preferences and still continues with this error.
This is an issue of a family member who is not computer savvy, and I really don't know much about Macs... Any solutions to this issue yet?

Re: Insufficient rights for saving file

Posted: Sat Nov 16, 2019 10:54 pm
by Simon
I'm not a developer, but going by this thread Deluge will need to be updated to work with the Catalina security changes. Until then there are a couple of workarounds that don't require granting it full disk access (which is a Bad Idea).

The Catalina restrictions apply to specific folders like Documents, Downloads and Desktop, so Deluge works fine if you point it at a folder outside these locations. For example, I moved my torrents folder from /Users/username/Documents/Torrents to /Users/username/Torrents. This is slightly harder to navigate to in Finder, which could be an issue if you're helping out non-technical friends or family, but you can create an alias to the new location on the desktop for them to easily get to their downloads (just don't try to point Deluge itself at this alias, or the restrictions on Desktop will kick in).

If for some reason you can't do that, a more clunky alternative is to run Deluge from a terminal window:


The app then "inherits" the permissions of Terminal, so by allowing Terminal to access your Documents folder or whatever Deluge will also be able to access it.

Re: Insufficient rights for saving file

Posted: Tue Mar 31, 2020 10:12 pm
by emri
Don't know if it's really a good idea, but adding bin/bash under "Full Disk Access" section in Preferences/Security & Privacy and Privacy tab resolved a similar problem for me (can't add torrent file from Downloads/Documents/...) ;)

  • Clic on +
  • hit [CMD+SHIFT+/]
  • type /bin
  • select bash

No need to let in this list

It's not an april fool :P

Re: Insufficient rights for saving file

Posted: Mon Jul 27, 2020 8:54 am
by Prisca22
Hi, I tried using your bin/bash idea, but when I click on +, I am sent right to the download folder, but I can't open it, only cancel. I am on MacOS Catalilna, trying to give Deluge access to my downloads folder. Thanks for any help... :-)