Page 1 of 1

Port problems

Posted: Sat Sep 02, 2017 6:51 pm
by TheD0Ct0R
Hi everybody,

I'm new here and obviously doing something wrong that I can't figure out. I would really appreciate some help from experts!

I'm running Deluge 1.3.15 on OS X El Capitan under a VPN, down and uploads work for few minutes and then stop with an Error.
I suspect is a port problem as the "Test Active Port" always fails. I have tried to change most of the settings, including opening ports on my router, using random or static ports but nothing really worked.

any suggestion would be more than welcome!

Re: Port problems

Posted: Sat Sep 02, 2017 10:57 pm
by gderf
"Test Active Port" will always fail if using a VPN or proxy.

Opening ports when using a VPN or proxy is pointless, and solves nothing.

Look elsewhere for the source of your problem and ask your VPN provider for help.

If your VPN provider offers access to their Proxy (mine does), then try that instead.

Re: Port problems

Posted: Sun Sep 03, 2017 3:42 am
by TheD0Ct0R
thank you for the reply, when I turn off the VPN I sill have the same issues, does it mean VPN is not the source of the problem?

Re: Port problems

Posted: Sun Sep 03, 2017 6:20 pm
by gderf
If you turn off the VPN (or proxy) then you must properly open a port to allow incoming connections or your downloads will crawl if they will download at all. So do what you must to have "Test Active Port" succeed.

However, when you disable VPN or proxy and you open a port your public IP address will be exposed and visible in the swarm to anyone else in the swarm. If you are torrenting legal content you should have no problem with this. But if the content is illegal you probably don't want to do this.

Re: Port problems

Posted: Sun Sep 10, 2017 7:44 am
by cappy
To get mine working I made sure my outgoing and incoming used the same port and specifically entered the IP of the VPN interface in settings. Test active port came back successful after this. I found the IP of my VPN using ifconfig and it usually gets the name tun1, tun2, etc. The port I used was the port forwarding port I received from my VPN provider.
Having this setup, a torrent through deluge worked a lot better then the same torrent in Transmission.

Re: Port problems

Posted: Fri Oct 16, 2020 3:08 am
by bmcelvan
I'm having this issue also. I normally use a VPN but for testing purposes I turned off the VPN and disabled the proxy in deluge. No matter what I do the Active Port is listed as 0 always. It never changes, I have multiple port ranges open in forwarding on my router and change them ranges in deluge settings but the active port number NEVER changes to anything other than 0.