Column setup not saved

Support for Deluge on Apple Mac OS
Cas
Top Bloke
Top Bloke
Posts: 3475
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Column setup not saved

Postby Cas » Wed Nov 27, 2013 3:13 pm

Unless you can provide more info there is nothing more I can do as testing on Linux shows no issues.

tigersoul
Member
Member
Posts: 22
Joined: Sat Nov 23, 2013 8:52 am
OS or Distro: Raspberry PI

Re: Column setup not saved

Postby tigersoul » Wed Nov 27, 2013 4:08 pm

You do have more info in patrickgmaris's post, if you tell him where the logs are at I'm sure he can provide that too. I'm not at the location for a few days where I'm using Deluge.

Cas
Top Bloke
Top Bloke
Posts: 3475
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Column setup not saved

Postby Cas » Wed Nov 27, 2013 7:02 pm

If that was suffice I would not have asked for more info, the screenshots simply confirm the issue but there is nothing to narrow down why it is happening...

There is an entire FAQ with an entry on logging...

patrickgmaris
New User
New User
Posts: 8
Joined: Sat Nov 23, 2013 7:20 pm
OS or Distro: OS 10.9/Windows 7+8

Re: Column setup not saved

Postby patrickgmaris » Wed Nov 27, 2013 7:18 pm

Cas wrote:Possibly a config issue, try deleting torrentview.state or the entire config (backup first)


I tried looking for the torrentview.state, but I couldn't find it. Can you give some more detailed instructions please? Greatly appreciate any help.

Thank you.

Cas
Top Bloke
Top Bloke
Posts: 3475
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Column setup not saved

Postby Cas » Wed Nov 27, 2013 8:02 pm


patrickgmaris
New User
New User
Posts: 8
Joined: Sat Nov 23, 2013 7:20 pm
OS or Distro: OS 10.9/Windows 7+8

Re: Column setup not saved

Postby patrickgmaris » Wed Nov 27, 2013 11:00 pm

So at first I deleted the .state files that pertained to torrents and tabs. Which didn't do much. Some of the columns came back to the same place when I re-checked them. I then changed the deluge config folder to .bak and tried again.

Nothing changed. Some more info: I am using the newest version and I am on 10.9.

tigersoul
Member
Member
Posts: 22
Joined: Sat Nov 23, 2013 8:52 am
OS or Distro: Raspberry PI

Re: Column setup not saved

Postby tigersoul » Thu Nov 28, 2013 6:12 pm

I've tried removing the suggested file from .config, no difference. How do i retrieve the log file? I tried looking for it in the .config folder but found nothing.

carbncl
Leecher
Leecher
Posts: 92
Joined: Sun Nov 28, 2010 7:36 pm

Re: Column setup not saved

Postby carbncl » Thu Nov 28, 2013 8:10 pm

For the record, reported that issue few months ago : viewtopic.php?f=13&t=39737&start=50#p183293

tigersoul
Member
Member
Posts: 22
Joined: Sat Nov 23, 2013 8:52 am
OS or Distro: Raspberry PI

Re: Column setup not saved

Postby tigersoul » Fri Nov 29, 2013 10:05 am

It's pretty clear it's a real issue, hopefully they can fix it.

Cas
Top Bloke
Top Bloke
Posts: 3475
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Column setup not saved

Postby Cas » Fri Nov 29, 2013 3:10 pm

'They' is pretty much just me currently and the fact it is isolated to OSX, which I don't run natively, means unless an exact commit or code issue can be shown it can't be fixed.

The log file is where ever you choose to store it with the command switch.

It would be interesting to know if the state file actually changes, can you provide a copy of the torrentview.state file, both after resetting the config and changing the columns.

carbncl wrote:For the record, reported that issue few months ago : viewtopic.php?f=13&t=39737&start=50#p183293

Ah I forgot you mentioned that. Are you able to test if it is actually a 1.3.5 or gtk change that caused this?

I can't think off-hand any commit would have affected only OSX saving the state file.

torrentview commit 1.3.5 to 1.3.6
All 1.3.5 to 1.3.6 GTK Commits


Return to “Mac OS”

Who is online

Users browsing this forum: No registered users and 1 guest