Deluge.app (Current version: 1.3.11)

Support for Deluge on Apple Mac OS
drizzle
New User
New User
Posts: 2
Joined: Tue Jul 08, 2014 11:03 pm

Re: Deluge.app (Current version: 1.3.9)

Postby drizzle » Sat Apr 04, 2015 11:42 pm

alexholliz wrote:I haven't had the deluge-deamon (1.3.6+) start on Mavericks or Yosemite with the button in the connection manager.


All of this. the stock Yosemite builds seem to break older python installs, (I haven't gotten Deluge to start with a connection manager yet on 10.10.2 either).

deluged_ude

Re: Deluge.app (Current version: 1.3.6)

Postby deluged_ude » Fri May 15, 2015 3:40 pm

xaeiou wrote:
doc wrote:
xaeiou wrote:Hi

I'm running the current version 1.3.6 of the app under osx 10.8.4. I did a "normal" install of the app. I'm running in classic GUI mode so I can manage both a local and remote daemon.

However, when I try to start the local daemon I get the message:

/deluged: line 69: /Applications/Deluge.app/Contents/Contents/MacOS/Deluge-python: No such file or directory


Thanks for posting this. My solution is a bit different than yours, and far from a solution.

When I tried running:

Code: Select all

sudo ./deluged &"


Nothing would happen, and the daemon wouldn't be running. When I omitted the quotation mark at the end, then I got the error:

Code: Select all

./deluged: line 66: /Applications/Deluge.app/Contents/Contents/MacOS/Deluge-python: No such file or directory


The issue is pretty obvious. One too many "/Contents"

So I loaded "deluged" into a text editor, went to line 66, which reads:

Code: Select all

$EXEC "$PYTHON" "$bundle_contents/MacOS/deluged-bin" "$@"


That sent me to the $bundle_contents variable (found at line 14). And the variable is defined as "$bundle"/Contents. I changed the line to remove "/Contents"

And then I ran:

Code: Select all

sudo ./deluged &


That starts things up (with an error about a missing Python library). And I can now see an active daemon in the Connection Manager.
Strangely, if I execute:

Code: Select all

sudo ./deluged &"

the daemon will not start.

It's dirty and doesn't work very well. For the time being, I'm going to install a second Torrent program for local torrents, and continue using Thin Client to access my Ubuntu Server's daemon.


Return to “Mac OS”

Who is online

Users browsing this forum: No registered users and 3 guests