[HOWTO] Install Deluge 1.3.3 with Macports

Support for Deluge on Apple Mac OS
carbncl
Leecher
Leecher
Posts: 92
Joined: Sun Nov 28, 2010 7:36 pm

Re: [HOWTO] Install Deluge 1.3.3 with Macports

Postby carbncl » Sat Oct 29, 2011 9:00 am

serine wrote:What carbncl is trying to suggest is for you to read the ticket and perhaps try updating your dependencies. This thread is hand-holdy as it gets for compiling Deluge for mac. Each system and setup is different and I wouldn't exactly say that it's uncommon to encounter hiccups.

I think this ticket has been fixed in macports since.

Cas
Top Bloke
Top Bloke
Posts: 3475
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: [HOWTO] Install Deluge 1.3.3 with Macports

Postby Cas » Sat Nov 05, 2011 6:34 pm

Thanks to work by carbncl he has created a standalone Deluge.app for 10.6 & 10.7. Please can you help by testing the latest version and report back to him.

Deluge.app build using GTK-OSX

fancyclown
Member
Member
Posts: 25
Joined: Mon Oct 01, 2007 8:21 pm

Re: [HOWTO] Install Deluge 1.3.3 with Macports

Postby fancyclown » Tue Oct 02, 2012 4:58 am

I have an intel iMac i386 so I can't use the app available thanks to carbncl. Therefore i tried Deluge with old faithful Macports again tonight. I have used this method before and everything has worked great, however after a successful install using:

Code: Select all

sudo port install boost +python27 gtk2 +no_x11+quartz deluge


there seems to be something wrong with the permissions. If I select to download a file to an external harddrive or even my torrent folder on the internal hdd somehow the download defaults to my home folder /Users/k. The same error happens when I try to set upp autoadd. The watched folder changes to /Users/k. I can browse all my hdds and folders with the Deluge filemanager but the settings don't stick.

Anyone know what the problem can be? I ran deluge with the debug setting enabled but that did not show anything. My download settings just won't stick, no warnings. All other settings works as they should and sticks, the problem is to access another folder than /Users/k. :(

Thanks for any help

EDIT solved it by using the i386 build of Deluge.app and made all the settings through that gui. The deluged daemon from macports works together with Deluge.app. Guess this workaround will work for now. :D I still have no idea why the gui from macports don't work properly though :?


Return to “Mac OS”

Who is online

Users browsing this forum: No registered users and 1 guest