[HOWTO] Install Deluge 1.3.3 with Macports

Support for Deluge on Apple Mac OS
Trust_no1
New User
New User
Posts: 3
Joined: Thu Feb 24, 2011 3:40 pm
OS or Distro: Mac OS X

Re: [HOWTO] Install Deluge 1.3.1 with Macports

Postby Trust_no1 » Sat Feb 26, 2011 1:02 pm

Hello,

I still have the same error, I do not understand I deleted the alias
org.freedesktop.dbus-system.plist in the library


Code: Select all

Error: Target org.macports.activate returned: Image error: /Library/LaunchDaemons/org.freedesktop.dbus-system.plist already exists and does not belong to a registered port.  Unable to activate port dbus. Use 'port -f activate dbus' to force the activation.
Error: Failed to install dbus
Log for dbus is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_dbus/main.log
Error: The following dependencies were not installed: dbus-python26 dbus dbus-glib glib2 gtk-doc docbook-xml docbook-xml-4.1.2 xmlcatmgr docbook-xml-4.2 docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils intltool gnome-common p5-getopt-long p5-pathtools p5-scalar-list-utils p5-xml-parser iso-codes libxslt libxml2 py27-libxml2 python27 rarian getopt py26-gobject libffi librsvg cairo fontconfig freetype libpixman libpng xrender xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb xorg-libpthread-stubs xorg-xcb-proto xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-renderproto gtk2 atk gdk-pixbuf2 jasper jpeg tiff pango Xft2 shared-mime-info xorg-libXcomposite xorg-compositeproto xorg-libXext xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto libart_lgpl libcroco libgsf gconf orbit2 libidl policykit eggdbus gnome-vfs desktop-file-utils popt gnome-mime-data libbonobo libtorrent-rasterbar libgeoip py26-chardet py26-distribute py26-game libsdl libsdl_image libsdl_mixer flac libogg libmikmod libvorbis smpeg libsdl_ttf py26-numpy atlas gcc44 gmp mpfr gzip texinfo xz fftw-3 py26-nose py26-gtk libglade2 py26-cairo py26-mako py26-notify-python libnotify py26-openssl py26-twisted py26-zopeinterface py26-twisted-web2 py26-xdg py26-numeric
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Cas
Top Bloke
Top Bloke
Posts: 3475
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: [HOWTO] Install Deluge 1.3.1 with Macports

Postby Cas » Sat Feb 26, 2011 3:47 pm

You should probably speak to macports about this then.

Trust_no1
New User
New User
Posts: 3
Joined: Thu Feb 24, 2011 3:40 pm
OS or Distro: Mac OS X

Re: [HOWTO] Install Deluge 1.3.1 with Macports

Postby Trust_no1 » Sun Feb 27, 2011 3:50 pm

I successfully installed Deluge, I'm trying how to make it executable
I could not walk someone gave her the power to executable launched
Thank you

serine
New User
New User
Posts: 4
Joined: Tue Apr 05, 2011 5:15 am
OS or Distro: OS X

Re: [HOWTO] Install Deluge 1.3.1 with Macports

Postby serine » Tue Apr 05, 2011 5:40 am

I created an account to give all of you a new development if you try to build Deluge.
As of April 4, 2011 the Macports Boost update (to 1.46.1) breaks libtorrent-rasterbar.

In order to make libtorrent successfully, you will have to use an older version of boost— rev @76350 seems to work for me so far. Here is a refresher on installing older ports.

EDIT: All macports work now, as of May, 2011.
Last edited by serine on Sun May 08, 2011 8:10 am, edited 1 time in total.

1NUY4SH4

Re: [HOWTO] Install Deluge 1.3.1 with Macports

Postby 1NUY4SH4 » Thu Apr 07, 2011 5:48 pm

About the computer I chose to install Deluge (for the first time):

Code: Select all

20" iMac (7,1), Mac OS X 10.6.7 (10J869), 2 GHz Intel Core 2 Duo, 2 GB 667 MHz DDR2 SDRAM, XCode V. 3.2.6 (1761)


I haven't updated XCode to V. 4.x yet... Though probably unrelated to Xcode version, I had a few issues with dependency ports, so here are the steps that worked best for me:

Code: Select all

:~$ sudo port selfupdate
:~$ sudo port upgrade outdated
:~$ sudo port install deluge


This eventually spit out the same +python26 error previously mentioned for me:

**** libtorrent-rasterbar requires port boost installed with variant +python26.


So, I ran:

Code: Select all

:~$ sudo port install boost +python26


But then, I still got an error installing libtorrent-rasterbar:

---> Building libtorrent-rasterbar
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install libtorrent-rasterbar


Thinking surely, someone else must have had this issue, I read through this thread to the post above about installing an older version of boost. Here are the steps I used:

Code: Select all

- Create a folder in my user directory ~/boost (though it does not matter where you create this folder, or probably if you even do). Also create a folder inside the same place: ~/boost/files in my case.

- Browse through [url=http://trac.macports.org/log/trunk/dports/devel/boost]the previously provided link[/url] to the repository and chose a previous revision, I used [url=http://trac.macports.org/browser/trunk/dports/devel/boost/Portfile?rev=76350]the port suggested[/url].

-Using the "Original Format" link at the bottom of the Portfile page, and the same for the files in the "files" folder.

- Move the Portfile into ~/boost and the other .diff files into ~/boost/files


The rest was easy:

Code: Select all

:~$ cd boost
:boost$ sudo port clean boost
:boost$ sudo port install +python26
--->  Deactivating boost @1.46.1_0+python26
--->  Activating boost @1.45.0_2+python26
:boost$ sudo port clean libtorrent-rasterbar
:boost$ sudo port install libtorrent-rasterbar
:boost$ sudo port install deluge


If you do not clean up libtorrent-rasterbar before you try reinstalling it, you may get the same "shell command failed" error that I did. YMMV, but it's probably safer to just clean it up first.

I realize that the original post must have been before the boost port update as mentioned. Whether the boost/libtorrent-rasterbar problem is an issue with boost directly (like bad update), or with libtorrent-rasterbar not updated yet to take advantage of the boost updates, I don't know.

I hope this helps someone who may not have had previous experience in installing Deluge, especially with installing older port dependencies.

carbncl
Leecher
Leecher
Posts: 92
Joined: Sun Nov 28, 2010 7:36 pm

Re: [HOWTO] Install Deluge 1.3.1 with Macports

Postby carbncl » Sat May 28, 2011 3:17 pm

1.3.2 version : Just submitted a very small patch to macports to upgrade port from 1.3.1 > 1.3.2

Looks like 1.3.2 is a minor update with mostly bugfixs and that no dependencies has changed. Works for me (But not fully tested, I just use the client to remote control a server)

turtle

Re: [HOWTO] Install Deluge 1.3.2 with Macports

Postby turtle » Mon Jul 18, 2011 8:52 pm

Hi -

I am completely new to Macs and was trying to install Deluge using the instructions provided. The install seems to be stuck at Building atlas or does this part just take a long time?

Code: Select all

--->  Attempting to fetch lapack-3.3.0.tgz from http://www.netlib.org/lapack
--->  Verifying checksum(s) for atlas
--->  Extracting atlas
--->  Applying patches to atlas
--->  Configuring atlas
--->  Building atlas


I don't want to restart it unless it continues where it left off.

Any help would be appreciated.

Turtle

mercury00

Re: [HOWTO] Install Deluge 1.3.2 with Macports

Postby mercury00 » Tue Jul 19, 2011 3:04 am

The 'mac port install' method of installing deluge doesn't work with yesterday's brand new bought mac. The libtorrent-rasterbar problem still exists, and requiring users to uninstall anything other programs depend on to get it to work is not a solution. Please remove mac as a supported operating system until it actually works. Thanks.

1NUY4SH4

Re: [HOWTO] Install Deluge 1.3.2 with Macports

Postby 1NUY4SH4 » Tue Jul 19, 2011 5:55 pm

mercury00 wrote:The libtorrent-rasterbar problem still exists, and requiring users to uninstall anything other programs depend on to get it to work is not a solution


What other programs are you running that have libtorrent-rasterbar as a dependency? also, did you try the fix above, of installing an older package of libtorrent-rasterbar?

carbncl
Leecher
Leecher
Posts: 92
Joined: Sun Nov 28, 2010 7:36 pm

Re: [HOWTO] Install Deluge 1.3.2 with Macports

Postby carbncl » Tue Jul 19, 2011 6:42 pm

mercury00 wrote:The 'mac port install' method of installing deluge doesn't work with yesterday's brand new bought mac. The libtorrent-rasterbar problem still exists, and requiring users to uninstall anything other programs depend on to get it to work is not a solution. Please remove mac as a supported operating system until it actually works. Thanks.

Deluge is not so easy to install on OSX (I've spent hours the first time I wanted to install it...) but it does works, at least (maybe) it does for some people... So imho, OSX should be listed as a supported OS...
I wished someone was capable of packaging it as an easy to install/use .app, but I'm afraid that because of all its dependencies (python, gtk...) it is not an easy task to do...

1NUY4SH4 wrote:What other programs are you running that have libtorrent-rasterbar as a dependency? also, did you try the fix above, of installing an older package of libtorrent-rasterbar?

for information, you can check using port command :

Code: Select all

~ > port dependents libtorrent-rasterbar
deluge depends on libtorrent-rasterbar


Return to “Mac OS”

Who is online

Users browsing this forum: No registered users and 1 guest