Weird download speed issue

Specific support for Deluge on Microsoft Windows OS
LouisCyr
New User
New User
Posts: 4
Joined: Thu Dec 31, 2020 4:21 pm

Weird download speed issue

Postby LouisCyr » Thu Dec 31, 2020 4:25 pm

I'm downloading a few torrents from different trackers, they all have a low numbers of seeders (2-5).
They are all downloading very slowly, like between 4k/s and 30k/s.

If I start any torrent with a lot of seed from any tracker, that torrent will reach a very high speed (50mb/s+) but will also boost the speed of my other slow downloading torrent from 4k/s to 1-2mb/s. Then when the fast downloading torrent finish, they all go back to 4-30k/s.
(The slow downloading torrents are on unrelated trackers and the fast downloading torrent as well)

I can reproduce it everytime. I've followed every guides I found on dev.deluge-torrent.org.

I have a 250gig torrent downloading right now at 4k/s, I can get it to 1-2mb/s if I download any another fast torrent on the side, on any random tracker. But then it goes back to 4k/s as soon as that torrent finish.

I'm using Deluge 1.3.15 on Windows 10

Looking for any tips or recommendations here :)

Thank you!

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1069
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Weird download speed issue

Postby mhertz » Thu Dec 31, 2020 6:33 pm

You could check if upgrading to latest supported libtorrent works better/fixes-it, curtesy of MikeMelbAustralia : viewtopic.php?f=12&t=55859

LouisCyr
New User
New User
Posts: 4
Joined: Thu Dec 31, 2020 4:21 pm

Re: Weird download speed issue

Postby LouisCyr » Thu Dec 31, 2020 6:55 pm

Thank you for your recommendation mhertz.

So I've closed my deluge. Updated libtorrent to 1.1.14 then reopened my deluge. My 250gig download did restart at around 30k/s and was fluctuating between 30 and 60k/s. Then I've downloaded a random torrent on another tracker with lot of seed. My 250gb torrent went directly to 2.2mb/s until the other torrent finished, then returned to 30k/s.

Total mystery.

mhertz wrote:You could check if upgrading to latest supported libtorrent works better/fixes-it, curtesy of MikeMelbAustralia : viewtopic.php?f=12&t=55859

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1069
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Weird download speed issue

Postby mhertz » Thu Dec 31, 2020 8:18 pm

That is indeed strange - have you just for testing tried e.g. qbittorrent or other client and seen if this is a strictly deluge problem, well libtorrent in your tested versions problem, as deluge shouldn't do such and just lets libtorrent handle such mostly. I could understand maybe somehow getting better connectivity/gained-peers/speed from more peers of other swarms, intermingled, but that it goes back down when other popular torrent finished is indeed strange as you stated.

Maybe it's an uTP issue, sometimes there can be speed problems because of latency miscalculations, though still sounds strange considering your specific circumstances, but wouldn't hurt imho to test with uTP disabled, by using ltconfig plugin and disabling incoming/outgoing uTP connections - just a thought.

Otherwise sorry i'm as stumped as you unfortunetly and hopefully others can chime in with better help.

LouisCyr
New User
New User
Posts: 4
Joined: Thu Dec 31, 2020 4:21 pm

Re: Weird download speed issue

Postby LouisCyr » Thu Dec 31, 2020 9:04 pm

Hmmm... I don't know why BUT I've just installed the ltconfig plugin and tried to first load the preset "High Performance Seed" and my slow download went to 10mb/s stable :|

Seems like there are settings somewhere in there that are doing a hell of a difference. Thank you for your suggestion, I think that's going to do it !

One last little thing since you are here: it seems like I can't see ltconfig in the preferences of my Deluge. I had to enable the WebUI to find the options, is that on purpose ? Didn't find much about that yet but didn't search a lot either since I found it in the webui.

Thanks a lot again!!


Edit: My slow download that was going for 1 week and had still a few weeks going just finished at over 30mb/s... thank you again!

mhertz
Compulsive Poster
Compulsive Poster
Posts: 1069
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: Weird download speed issue

Postby mhertz » Thu Dec 31, 2020 11:11 pm

Cool, I'm glad you found a solution/imorovement :) Sorry, I don't know why not shown in GTKUI, should be - I only know that v0.3.1 of ltconfig is officially supported for deluge under v2.0.x, and don't know if ltconfig v2.0 even works in GTKUI on deluge under 2.0, so if not already then try that, as else I don't know sorry.

LouisCyr
New User
New User
Posts: 4
Joined: Thu Dec 31, 2020 4:21 pm

Re: Weird download speed issue

Postby LouisCyr » Fri Jan 01, 2021 1:35 am

No worries, it's not that big of an issue, my download speed if finally fixed that's the most important thing.

Thanks again for your time.


Return to “Windows OS”

Who is online

Users browsing this forum: mhertz and 6 guests