Page 1 of 1

libtorrent 1.1.14.0 for Deluge 1.3.15

Posted: Wed Dec 30, 2020 2:10 am
by MikeMelbAustralia
1.1.14.0.png
1.1.14.0.png (16.59 KiB) Viewed 866 times
I recently found that I was getting periodic CPU usage spikes with Deluge 1.3.15 running on Windows (which comes with libtorrent 1.0.11.0). The spikes weren't huge or long in duration, but enough for the cooling fan on my i7 NUC to become loud enough to hear.

I found that upgrading to libtorrent 1.1.13 resolved this issue. This was downloaded here:
https://forum.deluge-torrent.org/viewtopic.php?t=55168

I have just compiled libtorrent 1.1.14 against OpenSSL 1.1.1i, with Python 2.7.18 installed.

It can be downloaded here:
https://drive.google.com/file/d/1GFotYWeNjViq_mqGTWBO81W89iXIrBZz/view?usp=sharing

There is a readme.txt inside with instructions on how to update. The usual disclaimers apply - use at your own risk, backup the older files in case you wish to roll-back, etc.

Kind Regards,

Mike

Edit: Changed link to Google Drive.

Re: libtorrent 1.1.14.0 for Deluge 1.3.15

Posted: Wed Dec 30, 2020 9:04 am
by mhertz
Nice, thank you for the contribution mate! :)

Re: libtorrent 1.1.14.0 for Deluge 1.3.15

Posted: Wed Dec 30, 2020 1:07 pm
by Bobby
Thanks mate, it worked fine :) I recently switched back to 1.3.15 :)

Re: libtorrent 1.1.14.0 for Deluge 1.3.15

Posted: Fri Jan 08, 2021 12:41 am
by 4NE
Thanks, It also work on 1.3.14 my main private tracker site do not allow Deluge 1.3.15 for some weird reason, heck all other builds work fine even unofficial 2.x builds.
That aside, I wonder if you can make libtorrent 1.2.x to work on Deluge 1.3.x too?
I tied Deluge 2.x with libtorrent 1.2.11 once it work best fast and resource effective but i have a solid reason to not use that build.

Re: libtorrent 1.1.14.0 for Deluge 1.3.15

Posted: Sun Jan 10, 2021 5:18 pm
by MikeMelbAustralia
Thank you for the feedback. :)

4NE wrote:That aside, I wonder if you can make libtorrent 1.2.x to work on Deluge 1.3.x too?


This was asked on the thread where I got instructions on how to compile libtorrent.
https://forum.deluge-torrent.org/viewtopic.php?t=55168

idiocracy wrote:Would it be possible that you could do one with libtorrent 1.2.1 ?


Nekotan wrote:It's not possible.

libtorrent 1.2 needs a newer msvc compiler then deluge 1.3 uses.
deluge 2.0 will have support for libtorrent 1.2 included in the source code I think

When deluge 2.0 has an installer for windows it will be possible :)


So it sounds like it is not possible. There is also the chance of API changes in 1.2.x that may be incompatible with Deluge 1.3.x. I'm sorry I can't be much help - I'm unfamiliar with the source and the build system. The only reason I got this to compile was thanks to Nekotan's instructions and some perseverance.