[Unofficial] Deluge 2.0.x installer

Specific support for Deluge on Microsoft Windows OS
eddycatboy
New User
New User
Posts: 7
Joined: Fri Nov 15, 2019 8:00 pm

Re: [Unofficial] Deluge 2.0.x installer

Postby eddycatboy » Thu Jul 09, 2020 6:58 am

mhertz wrote:Edit: After thinking about it some more, then no, that is for sure totally unrelated, so just scratch above statement. Also, I've tested the dev 36 build + previous versions, before on a physical win7 PC of a family-member(before upgrading it to win10), without any issue either.

If you say so, like i said before, it wasn't just Deluge's gui that wasn't working but also nox emu and Malwarebytes. At the time, certain gui of programs was not working, Deluge was just the first program that had that problem (and i still don't what even happen, or how it was fixed out of nowhere after a month). Again, just here to report and see if there anything here or any patch need, that's it.

mhertz
Compulsive Poster
Compulsive Poster
Posts: 795
Joined: Wed Jan 22, 2014 5:05 am
Location: Denmark

Re: [Unofficial] Deluge 2.0.x installer

Postby mhertz » Thu Jul 09, 2020 7:18 am

Sorry eddycatboy, I got it misconstrued lol :) Now I remember the issue you originally posted some time ago also. Good to hear doesn't happen anymore atleast. Anyway sorry for being slow :)

petersasi
Leecher
Leecher
Posts: 63
Joined: Sun Nov 17, 2019 8:09 am

Re: [Unofficial] Deluge 2.0.x installer

Postby petersasi » Thu Jul 09, 2020 12:44 pm

Glad to hear!
eddycatboy wrote:
petersasi wrote:Does that still crash for you?

I already said everything was working again, that was just an old log when my gui wasn't working, again i'm just here to show the log and report what happen since i forgot too.

Akito
New User
New User
Posts: 9
Joined: Sat Jun 20, 2020 10:07 am

Re: [Unofficial] Deluge 2.0.x installer

Postby Akito » Sun Jul 12, 2020 3:29 pm

I'm trying to use this release, however I cannot connect to my daemon in Thin Client mode, which however works fine with the official client.

petersasi
Leecher
Leecher
Posts: 63
Joined: Sun Nov 17, 2019 8:09 am

Re: [Unofficial] Deluge 2.0.x installer

Postby petersasi » Tue Jul 14, 2020 8:36 am

I am also using it in a thin clients + daemon setup.

Have you made sure both the client and the daemon are the same version? 2.x client cannot connect to an 1.x daemon and vice versa.

Akito wrote:I'm trying to use this release, however I cannot connect to my daemon in Thin Client mode, which however works fine with the official client.

Akito
New User
New User
Posts: 9
Joined: Sat Jun 20, 2020 10:07 am

Re: [Unofficial] Deluge 2.0.x installer

Postby Akito » Tue Jul 14, 2020 9:00 am

I was under the impression that I ran the 2.x daemon, but I have looked at the wrong Debian repository. I will try with a 2.x daemon. Seems like their authentication models also changed.

Akito
New User
New User
Posts: 9
Joined: Sat Jun 20, 2020 10:07 am

Re: [Unofficial] Deluge 2.0.x installer

Postby Akito » Tue Jul 14, 2020 2:17 pm

I've upgraded the daemon now. When I connect to it with the GUI, it starts up for about 3 seconds, then crashes without any errors or notifications. Using Windows 10 2004.

petersasi
Leecher
Leecher
Posts: 63
Joined: Sun Nov 17, 2019 8:09 am

Re: [Unofficial] Deluge 2.0.x installer

Postby petersasi » Tue Jul 14, 2020 3:06 pm

1. Could you start it specifying a log file with -l on the command line and log level with -L debug to see if there is any hidden errors message not yet seen?
2. Could you trying it with a brand new profile? (backup your deluge folder and remove it from the original location, deluge will create a new one.) there are a few settings which consistently crash deluge gtk on Windows.
3. Can you connect to the samey daemon with a thin client running on Linux and is the connection stable?
4. If you can, what are the client and daemon versions in the about Window there?
5. When using this installer did you try to install with all the different libtorrent versions included? Does the crash happen just the same with all three?


Akito wrote:I've upgraded the daemon now. When I connect to it with the GUI, it starts up for about 3 seconds, then crashes without any errors or notifications. Using Windows 10 2004.

Akito
New User
New User
Posts: 9
Joined: Sat Jun 20, 2020 10:07 am

Re: [Unofficial] Deluge 2.0.x installer

Postby Akito » Tue Jul 14, 2020 3:54 pm

Thank you very much for pointing out these very helpful hints. I forgot about the config directory. I deleted it, re-installed the client and then successfully connected to the daemon. In the meantime, the client had a little trouble finding the daemon, but when I set the daemon explicitly to listen on port 58846, it started to work. Don't know why I need to choose the default port explicitly when running the daemon, but this is not a big issue in my situation.

Thank your for the effort and help.

petersasi
Leecher
Leecher
Posts: 63
Joined: Sun Nov 17, 2019 8:09 am

Re: [Unofficial] Deluge 2.0.x installer

Postby petersasi » Wed Jul 15, 2020 4:03 pm

Glad to hear, have fun!

Akito wrote:Thank you very much for pointing out these very helpful hints. I forgot about the config directory. I deleted it, re-installed the client and then successfully connected to the daemon. In the meantime, the client had a little trouble finding the daemon, but when I set the daemon explicitly to listen on port 58846, it started to work. Don't know why I need to choose the default port explicitly when running the daemon, but this is not a big issue in my situation.

Thank your for the effort and help.


Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 3 guests