Update to 1.3.9

Specific support for Deluge on Microsoft Windows OS
mgermo
New User
New User
Posts: 3
Joined: Tue Oct 07, 2014 10:43 am

Update to 1.3.9

Postby mgermo » Tue Oct 07, 2014 10:58 am

Hello all. I was on 1.3.7 on win8 before today and got offered an upgrade. Yay. Anyway installation went without problems BUT now main area (where the torrents are) is unresponsive ie no down, up speed etc. I can right click and choose some option like remove torrent but nothing happens. If I add torrent via magnet link it wont show until i quit and open deluge again. However torrent is active...when I login via webui everything works. Tried reinstalling with no success. If I delete folder deluge in roaming all is ok, but I obviously dont want to lose settings. So either I remain on 1.3.7, go to 1.3.9 and lose settings or ?? Any other idea?

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Update to 1.3.9

Postby Cas » Tue Oct 07, 2014 11:30 am

Can you test in thinclient mode please, it could be some changes in gtkui we implemented have not worked as expected.

bro
Top Bloke
Top Bloke
Posts: 359
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: Update to 1.3.9

Postby bro » Tue Oct 07, 2014 1:21 pm

mgermo, could you make a zip of your directory deluge in roaming? You don't have to include the content of the state folder.
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.

mgermo
New User
New User
Posts: 3
Joined: Tue Oct 07, 2014 10:43 am

Re: Update to 1.3.9

Postby mgermo » Tue Oct 07, 2014 4:26 pm

Cas, its the same in Thin Client. I connect normally but its frozen. Its weird cause via webUI it works as intended.
bro, here it is http://www.filedropper.com/deluge
Something in (my) settings seem to clash with new version.

p.s.: zip is after I reverted to old version via Acronis, I presumed new version doesnt write anything in roaming folder thus they are the same

bro
Top Bloke
Top Bloke
Posts: 359
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: Update to 1.3.9

Postby bro » Wed Oct 08, 2014 12:16 am

mgermo, I think there is an issue with the LabelPLus plugin. Try to disable that and see if it works. I'm not sure where the bug is yet.
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.

bro
Top Bloke
Top Bloke
Posts: 359
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: Update to 1.3.9

Postby bro » Wed Oct 08, 2014 1:36 am

mgermo, I belive I have a fix. If you feel bold, you can edit the file deluge/ui/gtkui/listview.py and add the line as in:
https://github.com/bendikro/deluge/comm ... ad6cd1429f

P.S.
Make sure the indentation is exactly as in the commit, and use only spaces, no tabs.
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Update to 1.3.9

Postby Cas » Wed Oct 08, 2014 8:38 am

You don't need to edit anything, download the new file:

https://raw.githubusercontent.com/bendi ... istview.py

and drop it into deluge.egg/deluge/ui/gtkui folder where Deluge is installed.

mgermo
New User
New User
Posts: 3
Joined: Tue Oct 07, 2014 10:43 am

Re: Update to 1.3.9

Postby mgermo » Wed Oct 08, 2014 9:43 am

Issue is with LabelPlus. If I disable it, it works.
Fix also works.

bro
Top Bloke
Top Bloke
Posts: 359
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: Update to 1.3.9

Postby bro » Wed Oct 08, 2014 2:06 pm

mgermo wrote:Issue is with LabelPlus. If I disable it, it works.
Fix also works.

The bug is not in LabelPlus, but it only happens with plugins that add columns to the torrentview.
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.

feelfreetoblameme
Member
Member
Posts: 14
Joined: Tue May 06, 2014 8:23 pm

Re: Update to 1.3.9

Postby feelfreetoblameme » Wed Oct 08, 2014 6:41 pm

Cas wrote:You don't need to edit anything, download the new file:

https://raw.githubusercontent.com/bendi ... istview.py

and drop it into deluge.egg/deluge/ui/gtkui folder where Deluge is installed.


Thanks for this! I had also thought the problem was with the LabelPlus plugin but I'll attempt the fix. I'm on Ubuntu, by the way, same issue as Windows it seems.


Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 2 guests