high cpu usage...

Specific support for Deluge on Microsoft Windows OS
AlphaDream
New User
New User
Posts: 4
Joined: Thu Dec 05, 2013 5:40 pm

high cpu usage...

Postby AlphaDream » Tue Dec 10, 2013 11:55 am

Deluge is always using 6~12% of cpu (intel i5-4670k) while it is not seeding or downloading at all (I do have about 10 torrents queued up for seeding, but most of the time (almost always) nobody is downloading off of me),

the % is not very high but still unnecessary high I think?

is this normal?

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: high cpu usage...

Postby Cas » Fri Dec 13, 2013 1:01 pm

need a lot more information...

AlphaDream
New User
New User
Posts: 4
Joined: Thu Dec 05, 2013 5:40 pm

Re: high cpu usage...

Postby AlphaDream » Fri Dec 13, 2013 10:53 pm

what do you need? It happens immediately on startup,

CPU
Intel Core i5 4670K @ 3.40GHz 36 °C
Haswell 22nm Technology
RAM
12.0GB Dual-Channel DDR3 @ 800MHz (11-11-11-28)
Motherboard
MSI B85-G41 PC Mate(MS-7850) (SOCKET 0) 32 °C
Graphics
SMT24A350 (1920x1080@60Hz)
Intel HD Graphics 4600 (MSI)
Storage
1863GB Seagate ST2000DM001-1CH164 (SATA) 31 °C
111GB Samsung SSD 840 EVO 120GB (SSD) 27 °C
Optical Drives
No optical disk drives detected
Audio
ASUS Xonar DG Audio Device

AlphaDream
New User
New User
Posts: 4
Joined: Thu Dec 05, 2013 5:40 pm

Re: high cpu usage...

Postby AlphaDream » Mon Dec 16, 2013 6:35 pm

please help :(

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: high cpu usage...

Postby Cas » Tue Dec 17, 2013 12:33 am

Not the info we need... (hint: try reading forum rules about support requests)

AlphaDream
New User
New User
Posts: 4
Joined: Thu Dec 05, 2013 5:40 pm

Re: high cpu usage...

Postby AlphaDream » Sat Dec 21, 2013 7:37 pm

sorry for not following the guidelines!
--------------------------------------------
I have consulted the FAQ and I searched with no result,


- Deluge Version
Client: 1.3.6

- Libtorrent Version
libtorrent: 0.15.10.0

- Operating System Version
Windows 8.1 64-bit

- Plugins Enabled
none (just deluge install)

- WebUI, Console or GTK
??? (dont use web UI)

- Web Browser
have installed: Chrome, Waterfox (and IE)
only use Chrome

- Filesystem - ext4, ntfs, etc...
NTFS (standard)

- Installation Type - i.e. from source or package
from package

is it appropriate to upload log/config files?

Cas
Top Bloke
Top Bloke
Posts: 3642
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: high cpu usage...

Postby Cas » Mon Dec 23, 2013 4:37 pm

There are several topics in the forum about this and a ticket:

http://dev.deluge-torrent.org/ticket/2330

Thor77

Re: high cpu usage...

Postby Thor77 » Fri Jan 31, 2014 9:26 pm

I'm really curious about Deluge's future...it hasn't been updated for a long time...especially that high CPU usage that is known for a long time, why hasn't it been fixed yet?...I see a lot of threads that are unanswered...is deluge abandoned?

Simbiat
Member
Member
Posts: 46
Joined: Fri Jan 10, 2014 1:19 pm

Re: high cpu usage...

Postby Simbiat » Sun Feb 02, 2014 9:00 am

Thor77 wrote:I'm really curious about Deluge's future...it hasn't been updated for a long time...especially that high CPU usage that is known for a long time, why hasn't it been fixed yet?...I see a lot of threads that are unanswered...is deluge abandoned?

it's not. and if you check one of the nearest threads in this sub-forum - you will find link to the latest dev build for Windows. And it's a hot topic at that ;)

ThreatDown
New User
New User
Posts: 6
Joined: Thu Oct 18, 2007 1:04 am

Re: high cpu usage...

Postby ThreatDown » Sat Mar 08, 2014 5:58 am

I've noticed this too. deluge 1.3.6 on windows 8. i5-2500 processor. just idle seeding torrents deluge constantly using lots of cpu, 6-18%. in comparison qbittorrent or utorrent with the same torrents using 0-1%. Seems to be related to the gtk ui and/or classic mode. The GTK ui also seems to have a nasty memory leak in windows, mem usage just goes up the longer its open.

I've just started using the webui exclusively and disabled classic mode (just running the daemon). deluged by itself doesn't seem to have this cpu hunger issue, it uses 0-2% cpu idle as expected.


Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 8 guests