Magnet links refuse to associate

Specific support for Deluge on Microsoft Windows OS
Gizmo
New User
New User
Posts: 3
Joined: Thu Aug 02, 2018 7:55 pm
OS or Distro: Windows 10

Magnet links refuse to associate

Postby Gizmo » Thu Aug 02, 2018 7:58 pm

Hi! long time Deluge user here.
Running windows 10.

it's been bothering me for a while now (read several months).
during one of the big updates, I think the Fall Creators update, magnet links got dis-associated from Deluge. clicking them in chrome or Edge does nothing. checking in Regedit the keys are empty, even if I try to reinstall Deluge, or use Settings to try and associate them. I also tried to manually fill in the command to Deluge's install location but that disappeared as well after I reopened regedit!

I'm not sure what's going on, anyone have any clues?

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: Magnet links refuse to associate

Postby mhertz » Thu Aug 02, 2018 8:11 pm

Curtesy of fellow forum-member Piney:
undrline wrote:
Piney wrote:I recently had the same issue after installing u_torrent. I need 2 torrent programs because of private trackers that do not allow DHT.
U_torrent associated itself with magnet links which I didn't want it to do and the button in the deluge settings doesn't actually do anything.
I scoured the internet for about an hour trying to find a solution because the link in this post is dead.

To resolve this issue in 64bit windows open notepad and copy the following text:

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\magnet]
@="URL:MAGNET URI"
"URL Protocol"=""

[HKEY_CURRENT_USER\Software\Classes\magnet\DefaultIcon]
@="C:\\Program Files (x86)\\Deluge\\deluge.exe"

[HKEY_CURRENT_USER\Software\Classes\magnet\shell]

[HKEY_CURRENT_USER\Software\Classes\magnet\shell\open]

[HKEY_CURRENT_USER\Software\Classes\magnet\shell\open\command]
@="C:\\Program Files (x86)\\Deluge\\deluge.exe \"%1\""


Save as, choose desktop as the location and "all files" as file type then call it something like mag.reg
once you run the reg file hey presto magnets now working with deluge again.

If you have 32bit windows use the following

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\magnet]
@="URL:MAGNET URI"
"URL Protocol"=""

[HKEY_CURRENT_USER\Software\Classes\magnet\DefaultIcon]
@="C:\\Program Files\\Deluge\\deluge.exe"

[HKEY_CURRENT_USER\Software\Classes\magnet\shell]

[HKEY_CURRENT_USER\Software\Classes\magnet\shell\open]

[HKEY_CURRENT_USER\Software\Classes\magnet\shell\open\command]
@="C:\\Program Files\\Deluge\\deluge.exe \"%1\""

Works on Windows 10 Pro 64bit as well.

Source: viewtopic.php?t=39917#p195749

Gizmo
New User
New User
Posts: 3
Joined: Thu Aug 02, 2018 7:55 pm
OS or Distro: Windows 10

Re: Magnet links refuse to associate

Postby Gizmo » Sun Aug 05, 2018 9:23 pm

mhertz wrote:Curtesy of fellow forum-member Piney:


Hi, thanks for trying to help. I've gotten the registry keys to stick. I've compared them letter by letter to my laptop where it still works. it's identical to this reg file. I did save it down and added the keys to my registry (they are identical to what was already in there!) and it's still not working!

the registry for magnet links looks exactly the same!
on Desktop = not working
on laptop = working.

both running latest Win10 updates and chrome with deluge 1.3.15.

I am going crazy :(

shot a video to help illustrate my problem. excuse the hurried voice it's late. and inb4 "lol animenerd" :lol:
https://www.youtube.com/watch?v=-dqJnCO-no4 (unlisted)

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: Magnet links refuse to associate

Postby mhertz » Sun Aug 05, 2018 10:08 pm

There are several different "fixes" I found from googling this, and found a single page which lists all the fixes i've read about in one page, so check it out and also the comments as they come with a few suggestions too which helped others out where the main article steps didn't.

https://www.metserve.com/blog/magnet-li ... ith-chrome

Good luck! :)

(Also, rerun the deluge-installer to re-set the assoc's).

Gizmo
New User
New User
Posts: 3
Joined: Thu Aug 02, 2018 7:55 pm
OS or Distro: Windows 10

Re: Magnet links refuse to associate

Postby Gizmo » Tue Aug 07, 2018 8:25 pm

mhertz wrote:There are several different "fixes" I found from googling this, and found a single page which lists all the fixes i've read about in one page, so check it out and also the comments as they come with a few suggestions too which helped others out where the main article steps didn't.

https://www.metserve.com/blog/magnet-li ... ith-chrome

Good luck! :)

(Also, rerun the deluge-installer to re-set the assoc's).


yeah it's the same stuff I've already tried.

I have rerun the installer like 10 times, btw associations on the pc for .torrent files was never an issue, always worked.
it's only magnetlinks that won't work even though the registry is correct and from the looks of it chrome IS trying to open the link.

either completely blind missing something obvious in the registry or windows is somehow blocking it.

but then again it works just fine on my laptop :'(

mhertz
Seeder
Seeder
Posts: 158
Joined: Wed Jan 22, 2014 5:05 am
OS or Distro: Arch Linux

Re: Magnet links refuse to associate

Postby mhertz » Tue Aug 07, 2018 8:36 pm

Sorry, that's a bummer.

Try ctrl+shift+del and unselect all items and on advanced tab select just 'content settings', to reset chrome content settings back to default.

If not working, personally I would install qbittorrent or other free app and select associate magnets and see if that works to rule out a deluge issue and if that works uninstall qbittorrent and reinstall deluge.

Sorry, otherwise out of ideas - if only you where on linux i'd know exactly how magnets are controlled from chromium(xdg-open/desktop-files) :(


Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 2 guests