Search found 10 matches

by bolshoi
Mon Oct 25, 2021 2:27 pm
Forum: Mac OS
Topic: Deluge 2.0.3 on macOS 11.6 w/ Intel
Replies: 3
Views: 41479

Re: Deluge 2.0.3 on macOS 11.6 w/ Intel

The gettext error can be ignored, i get it all the time, no impact.

The other error is complaining about missing libtorrent looks like, try install with brew:

Code: Select all

brew install libtorrent-rasterbar
by bolshoi
Wed Oct 20, 2021 2:07 am
Forum: Mac OS
Topic: "Library not loaded: libffi" after upgrade to 3.4.2
Replies: 2
Views: 13656

Re: "Library not loaded: libffi" after upgrade to 3.4.2

I fixed this by running:

Code: Select all

pip3 install --force-reinstall cryptography
deluged seems to work for now.
by bolshoi
Tue Oct 19, 2021 3:41 pm
Forum: Mac OS
Topic: "Library not loaded: libffi" after upgrade to 3.4.2
Replies: 2
Views: 13656

Re: "Library not loaded: libffi" after upgrade to 3.4.2

original error: Traceback (most recent call last): File "/usr/local/bin/deluge", line 8, in <module> sys.exit(start_ui()) File "/usr/local/lib/python3.9/site-packages/deluge/ui/ui_entry.py", line 143, in start_ui ui.start() File "/usr/local/lib/python3.9/site-packages/deluge...
by bolshoi
Tue Oct 19, 2021 1:21 pm
Forum: Mac OS
Topic: "Library not loaded: libffi" after upgrade to 3.4.2
Replies: 2
Views: 13656

"Library not loaded: libffi" after upgrade to 3.4.2

I'm using Deluge daemon on MacOS. I upgraded libffi library via brew recently from 3.3_3 to 3.4.2. Deluge now fails with this error: dyld: Library not loaded: /usr/local/opt/libffi/lib/libffi.7.dylib I used a workaround from google: https://github.com/platformio/platform-lattice_ice40/issues/7 basic...
by bolshoi
Tue Aug 31, 2021 6:00 pm
Forum: Support
Topic: deluged 2 not starting after upgrade from 1.3 - module not found libtorrent
Replies: 5
Views: 7746

Re: deluged 2 not starting after upgrade from 1.3 - module not found libtorrent

Thank you for the details mhertz! I ended up downgrading libtorrent back to 1.2.10 and deluge is working normally again! For anyone else running into this, this is how I downgraded libtorrent-rasterbar via homebrew on macOS: brew tap-new bolshoi/local-libtorrent-rasterbar brew extract --version=1.2....
by bolshoi
Tue Aug 31, 2021 1:55 am
Forum: Support
Topic: deluged 2 not starting after upgrade from 1.3 - module not found libtorrent
Replies: 5
Views: 7746

Re: deluged 2 not starting after upgrade from 1.3 - module not found libtorrent

I have the same issue on macOS. I'll try your suggestion with building under -latomic.
Do I have to compile deluge under -latomic or libtorrent, or both?

Cheers!
by bolshoi
Sat Nov 28, 2020 4:14 pm
Forum: Mac OS
Topic: Assertion failed: (!surface->finished), function _cairo_surface_release_source_image, file cairo-surface.c, line 2092.
Replies: 2
Views: 24668

Assertion failed: (!surface->finished), function _cairo_surface_release_source_image, file cairo-surface.c, line 2092.

I'm running deluge (latest stable) on MacOS Big Sur. have been running under Python 3.9.0_1 (from Homebrew) Last night I upgraded latest python to 3.9.0_2 , and now when I try to launch deluge ui via deluge command in terminal, it crashed on launch returning this error: Assertion failed: (!surface->...
by bolshoi
Mon Oct 26, 2020 1:12 am
Forum: Plugins
Topic: [Plugin] Auto Remove Plus v2.0.0
Replies: 54
Views: 150275

Re: [Plugin] Auto Remove Plus v2.0.0

I changed it to check every 1 hour instead of 5. Also upgraded to python 3.9 (had to copy all plugins to the 3.9 instance and rename filenames to *-py3.9.egg), then manually reinstalled autoremoveplus 2.

Auto trigger is working now.

Cheers!
by bolshoi
Sun Oct 25, 2020 5:47 am
Forum: Plugins
Topic: [Plugin] Auto Remove Plus v2.0.0
Replies: 54
Views: 150275

Re: [Plugin] Auto Remove Plus v2.0.0

Thank you for updating this plugin! This is working on Deluge 2 on MacOS, except I noticed it doesn't automatically remove by itself (I have it set every 6 hours), but i can manually trigger it if I update anything in the settings and hit OK. Any clue why the auto trigger isn't working? I used to ha...