Search found 5 matches

by Senorsmartypants
Sun Jul 23, 2017 10:41 pm
Forum: Support
Topic: Lighttpd reverse proxy and "no such child resource"
Replies: 8
Views: 6150

Re: Lighttpd reverse proxy and "no such child resource"

After some more googling and looking at my other setups the issue was that there needed to be URL rewriting. Lighttpd does this differently depending on the version as explained in this post https://stackoverflow.com/questions/4859956/lighttpd-as-reverse-proxy So here is my working config for lightt...
by Senorsmartypants
Sun Jul 23, 2017 10:18 pm
Forum: Support
Topic: Lighttpd reverse proxy and "no such child resource"
Replies: 8
Views: 6150

Re: Lighttpd reverse proxy and "no such child resource"

I would still like to know if there's a deluge-web log I can look at. I'd be helpful to be able to tell what requests are being made and what is failing.
by Senorsmartypants
Sun Jul 23, 2017 10:11 pm
Forum: Support
Topic: Lighttpd reverse proxy and "no such child resource"
Replies: 8
Views: 6150

Re: Lighttpd reverse proxy and "no such child resource"

I didn't alter base in web config, I just wanted to show that I didn't alter it from "/" I have several other proxy setups working fine using lighttpd to other services. Just Deluge is causing a problem. Are there any people on here with working lighttpd proxy setups that work? Would you c...
by Senorsmartypants
Sun Jul 23, 2017 4:39 pm
Forum: Support
Topic: Lighttpd reverse proxy and "no such child resource"
Replies: 8
Views: 6150

Re: Lighttpd reverse proxy and "no such child resource"

Yes, I did. I also read some related posts where other people are having the same no such child resource issue. But it's usually a different web proxy, or they say to make sure there are slashes at the end of the base settings. Which I have tried and has not helped. The primary request is redirected...
by Senorsmartypants
Sat Jul 22, 2017 10:14 pm
Forum: Support
Topic: Lighttpd reverse proxy and "no such child resource"
Replies: 8
Views: 6150

Lighttpd reverse proxy and "no such child resource"

I'm trying to setup reverse proxy using Lighttpd to my deluge-web server and I'm running into the dreaded "no such child resource" error. I could use some help debugging this. Here's my setup Server A 192.168.1.1: Lighttpd 1.4.35 - proxy config server.modules += ( "mod_proxy" ) s...

Go to advanced search