Search found 30 matches

by alllexx
Fri Jun 24, 2016 12:00 pm
Forum: Development
Topic: Deluge develop minify issue when building from sdist tarball
Replies: 3
Views: 2398

Re: Deluge develop minify issue when building from sdist tarball

It would be nice to test for existence of minified .js during build, and skip this step, if they already exist. I see traces of this being done in setup.py, but it doesn't work properly. It doesn't make a big difference, but this way we can have tarballs that don't require python-slimit to be instal...
by alllexx
Fri Jun 24, 2016 11:57 am
Forum: Development
Topic: Deluge develop: Python argument types in session.post_torrent_updates(session) did not match C++ signature
Replies: 2
Views: 5545

Re: Deluge develop: Python argument types in session.post_torrent_updates(session) did not match C++ signature

Sorry for the bother, somehow I missed this while googling :-) I'm downgrading to 1.0.9, since deluge and deluge-develop are the only packages that use libtorrent-rasterbar on Optware-ng

P.S. And I confirm: downgrading to 1.0.9 works
by alllexx
Fri Jun 24, 2016 8:18 am
Forum: Development
Topic: Deluge develop: Python argument types in session.post_torrent_updates(session) did not match C++ signature
Replies: 2
Views: 5545

Deluge develop: Python argument types in session.post_torrent_updates(session) did not match C++ signature

I've recently upgraded deluge from develop branch to 53215d87 . I also upgraded libtorrent-rasterbar to 1.1.0. Deluge now spits this when I start it: Starting deluge daemon: deluged /opt/lib/python2.7/site-packages/deluge/_libtorrent.py:34: RuntimeWarning: to-Python converter for boost::shared_ptr<l...
by alllexx
Fri Jun 24, 2016 8:09 am
Forum: Development
Topic: Deluge develop minify issue when building from sdist tarball
Replies: 3
Views: 2398

Deluge develop minify issue when building from sdist tarball

Hi, I've recently upgraded deluge-develop package on Optware-ng from commit d91e5d89 to 53215d87 (currently the latest), and I've encountered this issue when trying to build from an sdist tarball: /home/jenkins/Optware-ng/buildroot-armeabi-ng/host/staging/opt/bin/python2.7 setup.py build running bui...
by alllexx
Wed Nov 11, 2015 3:10 pm
Forum: Development
Topic: Deluge on Android
Replies: 7
Views: 3241

Re: Deluge on Android

My /etc/hosts used to be pretty long, since it contained blocked ad sites (and it did contain "127.0.0.1 localhost"). I then issued `echo "127.0.0.1 localhost" > /etc/hosts`, but it didn't help. Honestly, I'm not sure whom to contact on this. Maybe, I should first try to run delu...
by alllexx
Sun Nov 08, 2015 2:35 pm
Forum: Development
Topic: Deluge on Android
Replies: 7
Views: 3241

Re: Deluge on Android

Cas, Sorry for the delay. Here's the traceback: root@tf101:/data/local # deluged root@tf101:/data/local # 14:33:33.794 [ERROR ][deluge.core.rpcserver:355 ] Couldn't listen on localhost:58846: [Errno -2] Name or service not known. Traceback (most recent call last): File "/opt/lib/python2.7/site-...
by alllexx
Fri Nov 06, 2015 1:33 pm
Forum: Development
Topic: Deluge on Android
Replies: 7
Views: 3241

Re: Deluge on Android

Cas, thank you for your reply! Here's error in dev mode: root@tf101:/data/local # deluged root@tf101:/data/local # 13:27:28.708 [ERROR ][deluge.core.rpcserver:355 ] Couldn't listen on localhost:58846: [Errno -2] Name or service not known. and here're lines 348-357: # Check for SSL keys and generate ...
by alllexx
Fri Nov 06, 2015 12:31 pm
Forum: Development
Topic: Deluge on Android
Replies: 7
Views: 3241

Re: Deluge on Android

Hm, no, deluged does work, but somewhat unstable. It is started OK by Optware-ng init.d script, but trying to stop it causes a reboot. If I disable deluged init script and reboot, and try to launch it later manually, I get the same error as above: root@tf101:/data/local # deluged root@tf101:/data/lo...
by alllexx
Fri Nov 06, 2015 12:12 pm
Forum: Development
Topic: Deluge on Android
Replies: 7
Views: 3241

Deluge on Android

Has anyone tried to run Deluge on Android? Deluge from develop branch (20150922) I installed on my Asus TF-101 using my Optware-ng project (look here to learn how) gives this error: root@tf101:/data/local # deluged root@tf101:/data/local # 12:04:21 [ERROR ][deluge.core.rpcserver] Couldn't listen on ...
by alllexx
Sun Sep 06, 2015 5:31 am
Forum: Development
Topic: deluge-web 0a12d1507 (20150901) starts ?dev=true by default
Replies: 7
Views: 1816

Re: deluge-web 0a12d1507 (20150901) starts ?dev=true by defa

Thanks to this commit http://git.deluge-torrent.org/deluge/commit/?h=develop&id=caf35bcdf470c3c59fbde1d47126e06d74c3e10a `python setup.py install` can now be used to generate more slim packages. I just need to edit 'RELEASE-VERSION' to not include 'dev' (this is outside git tree, of course), and...

Go to advanced search