GTK UI won't connect

General support for problems installing or using Deluge
Beebee
New User
New User
Posts: 2
Joined: Tue Sep 12, 2017 8:05 pm
OS or Distro: ubuntu

GTK UI won't connect

Postby Beebee » Tue Sep 12, 2017 8:28 pm

I did a search, and checked all the relevant threads I found. Did not find anything that matches this incidence.

Using Raspbian Wheezy as a server platform. Deluge version 1.3.3. Running just fine. I've used this installation for a couple of years now. Upgraded the thin-client desktop to Ubuntu 14.04 earlier this year - since then the GTK UI will not connect. Just now getting around to trying to fix it. GTK UI Deluge version is 1.3.15.

I can get the web ui to show me the status of things on the server, but I don't know how to use it to manage torrent downloads while on the client. That GTK UI is the primary reason I use Deluge. In the past, it just worked. Today, it doesn't.

I've checked all the firewall settings - both sides. Turned the firewalls off whilst tinkering, just to be sure.
Server-side file permissions are properly set (0755).
Logged out of both machines and rebooted.
Router firewall is appropriately forwarding the incoming port to the server.

So, any ideas why the GTK UI isn't working? The support pages say it should - as major version (1.3.x) is the same, but is it possible the minor versions have gone too far apart? Suggested resolutions?

Cas
Top Bloke
Top Bloke
Posts: 3466
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: GTK UI won't connect

Postby Cas » Wed Sep 13, 2017 7:13 am

Short answer for security you need to upgrade from 1.3.3. Long answer is something that has been covered many times and is in the forum.


Return to “Support”

Who is online

Users browsing this forum: Bing [Bot] and 9 guests