[Plugin] LabelPlus v0.3.2.2

Suggest, post, or discuss plugins for Deluge
Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am
OS or Distro: Windows 7

Re: [Plugin] LabelPlus v0.3.2.1

Postby Ratanak » Sun Oct 18, 2015 4:24 pm

@Itanaman

I think you have a different problem. The download location feature of this plugin actually *moves* from the default location to the download location specified for the label. All torrents will start in the default location, so if you let it start automatically, it will see nothing is at the default location and start downloading. That's the way Deluge does things. This is fine for new torrents since LabelPlus uses the move api to get the data to the configured label download location. If you are importing, I recommend enabling "add torrents in paused state" and then force rechecking the torrents (you will have to force recheck anyway since Deluge does not know your torrent state).

As for your suggestion, this is already possible. Enable "Label filter includes sublabels".

Holymartyr
New User
New User
Posts: 6
Joined: Tue Sep 22, 2015 2:06 am
OS or Distro: Windows

Re: [Plugin] LabelPlus v0.3.2.1

Postby Holymartyr » Tue Oct 20, 2015 3:07 am

Holymartyr wrote:I cannot get your newest (3.0+) versions of LabelPlus to work. I'm using Deluge 1.3.12 python2.6 as a server on a Windows Server 2008 Enterprise x64, with a Deluge 1.3.12 python2.6 as a client on Windows 7 x64. Before today, I was using Deluge 1.3.10 with version 0.2.18 of LabelPlus. That worked fine. I tried your new 0.3.2.1 version, and it would not work. So I updated Deluge to 1.3.12, and tried your updated plugin again. Still would not load.

Any advice on how to get you information that will help us?

P.S. I also use your other plugin MoveTools, and your updated version of MoveTools works just fine.


Bump? =( Would love to use the new features of LabelPlus >.<

Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am
OS or Distro: Windows 7

Re: [Plugin] LabelPlus v0.3.2.1

Postby Ratanak » Tue Oct 20, 2015 3:35 am

@Holymartyr

Are you using the 2.6 eggs? I still haven't updated to 1.3.12 so I haven't been able to test with that version yet.

Holymartyr
New User
New User
Posts: 6
Joined: Tue Sep 22, 2015 2:06 am
OS or Distro: Windows

Re: [Plugin] LabelPlus v0.3.2.1

Postby Holymartyr » Wed Oct 21, 2015 3:37 am

Correct, I am using the 2.6 eggs. I tried uninstalling and re-installing the 2.7 version for windows to try your plugins, and got the same result.

I tried LabelPlus with both 1.3.10 and 1.3.12 of Deluge, same result with both. MoveTools has been working wonderfully on 1.3.12.

Is there some sort of log, or debug - or anything that I can do for you?

Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am
OS or Distro: Windows 7

Re: [Plugin] LabelPlus v0.3.2.1

Postby Ratanak » Sat Oct 24, 2015 4:22 pm

You could try running Deluge with debug output on.

For the client: deluge-debug.exe -L debug -l <logfile>
For the server: deluged-debug.exe -L debug -l <logfile>

Look in the log files for exceptions and 'LabelPlus'. You might have to shutdown Deluge so that the logs are written to disk.

Holymartyr
New User
New User
Posts: 6
Joined: Tue Sep 22, 2015 2:06 am
OS or Distro: Windows

Re: [Plugin] LabelPlus v0.3.2.1

Postby Holymartyr » Sun Oct 25, 2015 4:49 am

Ok so I did that with both the client and the server, and tried running v0.3.2.1 of LabelPlus. I never got any errors, or anything abnormal in the server log, however in the cmd window I started up to do the logging, deluged.exe (server) spit out this:

Code: Select all

Unhandled Error
Traceback (most recent call last):
  File "deluge\main.py", line 230, in start_daemon

  File "deluge\core\daemon.py", line 171, in __init__

  File "twisted/internet/base.py", line 1194, in run

  File "twisted/internet/base.py", line 1203, in mainLoop

--- <exception caught here> ---
  File "twisted/internet/base.py", line 825, in runUntilCurrent

  File "build/bdist.linux-x86_64/egg/labelplus/core/core.py", line 146, in _initialize

  File "build/bdist.linux-x86_64/egg/labelplus/core/core.py", line 221, in _load_config

  File "build/bdist.linux-x86_64/egg/labelplus/common/config/__init__.py", line188, in init_config

  File "build/bdist.linux-x86_64/egg/labelplus/common/config/convert.py", line 68, in convert

  File "build/bdist.linux-x86_64/egg/labelplus/common/config/convert.py", line 84, in process_spec

exceptions.KeyError: '*'


The client only shows these mentionable bits of info in the log:

Code: Select all

[INFO    ] 00:37:22 gtkui:127 [LabelPlus] Initializing GtkUI...
[DEBUG   ] 00:37:22 pluginmanagerbase:156 Adding LabelPlus to enabled_plugins list in config
[INFO    ] 00:37:22 pluginmanagerbase:158 Plugin LabelPlus enabled..
[DEBUG   ] 00:37:37 gtkui:139 [LabelPlus] Waiting for core to be initialized... (spams this about 25 times)
[INFO    ] 00:39:54 gtkui:190 [LabelPlus] Deinitializing GtkUI...
[INFO    ] 00:39:54 gtkui:220 [LabelPlus] Unloading extensions...
[INFO    ] 00:39:54 reference_tracker:78 [LabelPlus] Running garbage collector...
[INFO    ] 00:39:54 reference_tracker:80 [LabelPlus] References collected: 0
[INFO    ] 00:39:54 reference_tracker:83 [LabelPlus] Remaining reference count: 1
[INFO    ] 00:39:54 gtkui:205 [LabelPlus] GtkUI deinitialized
[DEBUG   ] 00:39:54 component:256 Deregistering Component: GtkPlugin.LabelPlus
[INFO    ] 00:39:54 pluginmanagerbase:170 Plugin LabelPlus disabled..

Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am
OS or Distro: Windows 7

Re: [Plugin] LabelPlus v0.3.2.1

Postby Ratanak » Sun Oct 25, 2015 6:01 am

Looks like an issue with the config conversion. What version of LabelPlus generated the config file? Older ones are supposed to be converted to the newer, but I guess there is a bug somewhere. If you don't have too many labels, should probably delete the config and start fresh. Or you could send me the config file and I'll see if I can get it converted.

Holymartyr
New User
New User
Posts: 6
Joined: Tue Sep 22, 2015 2:06 am
OS or Distro: Windows

Re: [Plugin] LabelPlus v0.3.2.1

Postby Holymartyr » Mon Oct 26, 2015 1:55 am

Sure, I'll find somewhere to upload the file, and PM you a link. I swore I tried backing up/deleting the config, because that was one of the first things that came to mind when the update failed. Thanks for all your help!

I would delete it outright, but I do have a decent amount of labels. If you don't want to sort through my large file, don't hesitate to tell me lol, looks like a lot of work >.<

Oh, and iirc, I haven't updated LabelPlus since I got it, so it should be LabelPlus-0.2.18-py2.6 that generated the config file. That's still the version I'm using that works.

Ratanak
Leecher
Leecher
Posts: 98
Joined: Sat Dec 22, 2012 4:47 am
OS or Distro: Windows 7

Re: [Plugin] LabelPlus v0.3.2.2

Postby Ratanak » Tue Oct 27, 2015 2:35 am

Version updated to 0.3.2.2.

Fixed the config conversion issue for people updating from early versions of LabelPlus.

Holymartyr
New User
New User
Posts: 6
Joined: Tue Sep 22, 2015 2:06 am
OS or Distro: Windows

Re: [Plugin] LabelPlus v0.3.2.2

Postby Holymartyr » Tue Oct 27, 2015 3:58 am

Yay! It's working perfectly without any config changes ^^

Thank you so much Ratanak! Loving the new features


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 19 guests