[Plugin] YaRSS2 - RSS plugin with GTKUI support

Suggest, post, or discuss plugins for Deluge

YaRSS2 feed interval time

Postby nicolasolmstead » Thu Oct 04, 2012 4:28 pm

Is there a way to make it so it updates the rss feed like every 2 minutes instead of the lowest number of 15 minutes
nicolasolmstead
New User
New User
 
Posts: 1
Joined: Thu Oct 04, 2012 4:26 pm

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Cas » Thu Oct 04, 2012 4:38 pm

Mefiras wrote: I can add RSS feed fine, but when I am trying to save new subscription I get the following errors (in console) and the window won't close:

I don't use this plugin but the error suggests a missing/empty field.

Mefiras wrote:I also get the following errors when I first open new subscription window:

libglade warnings can be ignored.

@Bro you could set glade designer to either 2.12 or 2.16 glade version.
Cas
Developer
Developer
 
Posts: 2386
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby bro » Thu Oct 04, 2012 8:07 pm

UnnA^ wrote:That version worked bro! Deluge just needed to be restarted, how embarrassing :oops: Thanks heaps man, appreciate it! :D

Just wondering if it's possible to set the update internal to anything less than 15 mins? I try to set it lower but it defaults back to 15 minutes? Also what is "Obey TTL"?

Thanks.

Cool, I'll put out a new version with the fix.

15 minutes minimum is set to avoid people stressing the server. Are there any torrent RSS Feeds that update more often than every 15 minutes?
Obey TTL, uses the value of the TTL tag of the RSS Feed as the update interval (explained in the tooltip if you leave the mouse pointer over the checkbox). This is usually 60 minutes.
Server: Deluge 1.3.6, FreeBSD 9.2. Python 2.7.6, Libtorrent 0.16.13
Client: Deluge 1.3.6, Ubuntu 13.04. Python 2.7.4, libgtk 2.24.4
bro
Super Seeder
Super Seeder
 
Posts: 274
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: YaRSS2 feed interval time

Postby bro » Thu Oct 04, 2012 10:08 pm

nicolasolmstead wrote:Is there a way to make it so it updates the rss feed like every 2 minutes instead of the lowest number of 15 minutes

The minimum value is set to 15 minutes to avoid stressing the servers. Do you really need to update more often?
Server: Deluge 1.3.6, FreeBSD 9.2. Python 2.7.6, Libtorrent 0.16.13
Client: Deluge 1.3.6, Ubuntu 13.04. Python 2.7.4, libgtk 2.24.4
bro
Super Seeder
Super Seeder
 
Posts: 274
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby bro » Thu Oct 04, 2012 10:12 pm

Mefiras wrote:I wondering if anyone can help me with an error in YaRSS2. I have this seedbox running on Ubuntu and I've started using Deluge as my torrent client. I've chosen YaRSS2 as a plugin for RSS downloading.
I've installed the following version “YaRSS2-1.0.4-py2.6.egg”. I can add RSS feed fine, but when I am trying to save new subscription I get the following errors (in console) and the window won't close:
Code: Select all
Traceback (most recent call last):
File “/home/hd2/dobroezlo/.config/deluge/plugins/YaRSS2-1.0.4-py2.6.egg/yarss2/gtkui/dialog_subscription.py”, line 513, in on_button_save_subscription_clicked
File “/home/hd2/dobroezlo/.config/deluge/plugins/YaRSS2-1.0.4-py2.6.egg/yarss2/gtkui/dialog_subscription.py”, line 522, in save_subsription_data
AttributeError: ‘NoneType’ object has no attribute ‘strip’


I also get the following errors when I first open new subscription window:
Code: Select all
(deluge:16042): libglade-WARNING : unknown property `has_entry’ for class `GtkComboBox’
(deluge:16042): libglade-WARNING *: unknown property `entry_text_column’ for class `GtkComboBox’
(deluge:16042): libglade-WARNING : unknown property `has_entry’ for class `GtkComboBox’
(deluge:16042): libglade-WARNING *: unknown property `entry_text_column’ for class `GtkComboBox’


Any ideas what might be the problem here?


Can you try a newer version (preferably 1.1.1) ? You need to restart Deluge after adding a new version.
Server: Deluge 1.3.6, FreeBSD 9.2. Python 2.7.6, Libtorrent 0.16.13
Client: Deluge 1.3.6, Ubuntu 13.04. Python 2.7.4, libgtk 2.24.4
bro
Super Seeder
Super Seeder
 
Posts: 274
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby gqsmooth » Thu Oct 04, 2012 11:23 pm

Hey Bro,

I'm having a little trouble installing this plugin. I'm running Deluge 1.3.5 on a seedbox. I am trying to install the YaRSS2 plugin through the thin client on my Windows 7 machine. I go to preferences > pluging > install plugin and select the 2.6 egg that I downloaded and hit ok. Nothing happens. I even tried installing it through the WebUI but still, no dice. I have restarted deluge and checked to see if it took after both methods and still, no dice. The plugin is getting uploaded to the deluge/config/plugins folder on my seed box but why is no option for YaRSS showing up in the available plugins list? Any help would be appreciated.
gqsmooth
New User
New User
 
Posts: 9
Joined: Thu Oct 04, 2012 11:04 pm

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby UnnA^ » Fri Oct 05, 2012 12:04 am

I would really appreciate being able to have a limit lower than 15 mins as i use mine on a seedbox so ever minute is crucial when it comes to boosting ratio on private torrent sites. 15 minutes in my opinion is just too long because when you do get the torrent you miss out on seeding it to a lot of people that you could have. Really its up to you though. I appreciate all your hard work on this plugin :)

I'm not sure if it's in deluge itself but is it possible to add a maxfilesize command? E.G. if a release is bigger than a pre-defined size, it will not download? I use it for the example, i download the TV show Dexter and my rss filter is set to download anything that says "Dexter". But at the end of a season they quite often release a 30~GB pack of all the 720p releases or something like that which i don't want to download as it will kill my ratio. So yeah, can you possibly introduce something to the rss plugin that won't download files over a certain size?

Thanks!
UnnA^
New User
New User
 
Posts: 8
Joined: Tue Oct 02, 2012 4:53 am

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Mefiras » Fri Oct 05, 2012 7:54 am

bro wrote:Can you try a newer version (preferably 1.1.1) ? You need to restart Deluge after adding a new version.

Hi, thanks for the response. I've just updated it to 1.1.1 and restarted Deluge after that. The error looks similar, but in other files:

Traceback (most recent call last):
File "build/bdist.linux-x86_64/egg/yarss2/gtkui/dialog_subscription.py", line 547, in on_button_save_subscription_clicked
File "build/bdist.linux-x86_64/egg/yarss2/gtkui/dialog_subscription.py", line 556, in save_subsription_data
AttributeError: 'NoneType' object has no attribute 'strip'
Mefiras
New User
New User
 
Posts: 5
Joined: Thu Oct 04, 2012 12:04 pm

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby UnnA^ » Fri Oct 05, 2012 8:40 am

I have a small issue, it doesn't really bother me but when you run deluge in windowed mode, like not in full screen and start to add a subscription, Deluge always crashes with a runtime error.

Pic - http://www.upl.co/uploads/error-35.jpg

It only does it when deluge is not in fullscreen mode which is kind of wierd. Doesn't affect me but I'm just reporting bugs if i find them.

Cheers.
UnnA^
New User
New User
 
Posts: 8
Joined: Tue Oct 02, 2012 4:53 am

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby bro » Fri Oct 05, 2012 11:07 am

gqsmooth wrote:Hey Bro,

I'm having a little trouble installing this plugin. I'm running Deluge 1.3.5 on a seedbox. I am trying to install the YaRSS2 plugin through the thin client on my Windows 7 machine. I go to preferences > pluging > install plugin and select the 2.6 egg that I downloaded and hit ok. Nothing happens. I even tried installing it through the WebUI but still, no dice. I have restarted deluge and checked to see if it took after both methods and still, no dice. The plugin is getting uploaded to the deluge/config/plugins folder on my seed box but why is no option for YaRSS showing up in the available plugins list? Any help would be appreciated.

If the seedbox runs Python 2.7, it might require the 2.7 egg. In that case you'd have to install it manually. Can you find out which Python version it has?
Server: Deluge 1.3.6, FreeBSD 9.2. Python 2.7.6, Libtorrent 0.16.13
Client: Deluge 1.3.6, Ubuntu 13.04. Python 2.7.4, libgtk 2.24.4
bro
Super Seeder
Super Seeder
 
Posts: 274
Joined: Sun Aug 28, 2011 6:46 pm
Location: Norway

PreviousNext

Return to Plugins

Who is online

Users browsing this forum: Google [Bot] and 5 guests