[Plugin] YaRSS2 - RSS plugin with GTKUI support

Suggest, post, or discuss plugins for Deluge
GrapedUp
New User
New User
Posts: 1
Joined: Thu Aug 04, 2016 3:01 am
OS or Distro: Windows

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby GrapedUp » Thu Aug 04, 2016 3:04 am

Is there a list of supported indexers anywhere? With KAT gone I'm having trouble finding a public indexer with RSS support for search queries.

roraz
New User
New User
Posts: 2
Joined: Sun Sep 04, 2016 12:34 pm
OS or Distro: osx el capitain

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby roraz » Sun Sep 04, 2016 12:45 pm

I'm hoping someone can help. I have added my rss feeds and Im trying to add a subscription, but when I do, at the bottom of the subscription window I get the error message:

<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>

I know its not the feeds as I have tried generic public rss feeds and still get the same message. I have searched this forum and saw one or two people had the same issue, but no fix or resolution was made.

Does anybody know what the problem is and how I could fix it please?

Topfpflanzn
New User
New User
Posts: 2
Joined: Wed Oct 12, 2016 11:22 am
OS or Distro: Windows 7

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Topfpflanzn » Wed Oct 12, 2016 11:29 am

roraz wrote:...
<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>

I have had the exact same problem since the update to Deluge 1.3.13. Before that I used a Python 2.6 version of YaRSS2 and everything was working perfectly. After the update to 1.3.13 I had to install the Python 2.7 YaRSS2 egg (version 1.4.3) and my RSS feeds stopped working. I've done a complete uninstallation of Deluge and reinstalled with YaRSS2 1.4.3 Python 2.7 but still the same issue... :cry:
I'm on Windows 7 btw.

gggirlgeek
Member
Member
Posts: 13
Joined: Mon Oct 10, 2016 11:59 pm
OS or Distro: Windows 7 x64

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby gggirlgeek » Thu Oct 13, 2016 2:48 am

Topfpflanzn wrote:
roraz wrote:...
<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>

I have had the exact same problem since the update to Deluge 1.3.13. Before that I used a Python 2.6 version of YaRSS2 and everything was working perfectly. After the update to 1.3.13 I had to install the Python 2.7 YaRSS2 egg (version 1.4.3) and my RSS feeds stopped working. I've done a complete uninstallation of Deluge and reinstalled with YaRSS2 1.4.3 Python 2.7 but still the same issue... :cry:
I'm on Windows 7 btw.


I get this error when I use https in my feeds. Try using http. I also get something similar (authentication failed) when connecting over a proxy. In that case you need to add the feed's domain to your proxy exception list. For example, add "showrss.info" (no quotes) to your proxy exceptions.

It would be nice if a fix for this could be found.
Deluge v1.13
libtorrent v1.09.09
Seedbox: Debian 8.6
Client on: Win7x64

Topfpflanzn
New User
New User
Posts: 2
Joined: Wed Oct 12, 2016 11:22 am
OS or Distro: Windows 7

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Topfpflanzn » Thu Oct 13, 2016 7:36 am

gggirlgeek wrote:I get this error when I use https in my feeds. Try using http.
...

Thanks a lot! That did it. :)

roraz
New User
New User
Posts: 2
Joined: Sun Sep 04, 2016 12:34 pm
OS or Distro: osx el capitain

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby roraz » Sun Oct 16, 2016 11:46 am

gggirlgeek wrote:
Topfpflanzn wrote:
roraz wrote:...
<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>

I have had the exact same problem since the update to Deluge 1.3.13. Before that I used a Python 2.6 version of YaRSS2 and everything was working perfectly. After the update to 1.3.13 I had to install the Python 2.7 YaRSS2 egg (version 1.4.3) and my RSS feeds stopped working. I've done a complete uninstallation of Deluge and reinstalled with YaRSS2 1.4.3 Python 2.7 but still the same issue... :cry:
I'm on Windows 7 btw.


I get this error when I use https in my feeds. Try using http. I also get something similar (authentication failed) when connecting over a proxy. In that case you need to add the feed's domain to your proxy exception list. For example, add "showrss.info" (no quotes) to your proxy exceptions.

It would be nice if a fix for this could be found.


Im not using a proxy so I don't think that's it. Ive tried removing the 's' from the http however Im still getting the error message. I might be putting in my rss details wrong, so if someone could help that would be great?

the rss feed is: http://torrentsite.com/rss.php?feed=dl: ... d9f9d43bf1

What do I enter as the rss url in yarss2, and what cookies and values do I need to put in the cookies section? ie would it be:

http://torrentsite.com/rss.php - or - http://torrentsite.com/rss.php?feed=

dl - COOKIE
uid - 269239
pass - 1f1601add6005726dfa6ecd9f9d43bf1

Spadge
Leecher
Leecher
Posts: 96
Joined: Sat Dec 13, 2008 4:17 pm

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Spadge » Sun Oct 16, 2016 11:49 am

bro wrote:YaRSS2 is an RSS plugin for Deluge administered through the GTK Client interface.

Latest version: 1.4.3 (2015-11-14)

[*] Support for setting a label using the label plugin.


Hi there.

I've set up a subscription and it's not adding the label on when it adds the torrent.

I've picked it from the list in the YaRSS2's Edit Subscription > Options screen, where it correctly shows the available labels I've given Deluge.

I'm running a Deluge 1.3.13 client/server setup with the server running in Ubuntu Mate 16.04 and the client running in Ubuntu Mate 16.10. The subscription is adding the torrents fine, it's just the labels that aren't being added.

Thanks for any suggestions on how to troubleshoot this problem.

galneon
Member
Member
Posts: 21
Joined: Mon May 18, 2015 3:24 pm
OS or Distro: Win 7/8.1

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby galneon » Fri Oct 28, 2016 5:02 pm

I'm experiencing frequent ThinClient disconnects. I've never had a single unexpected client disconnect in my years of using Deluge until I began using YaRSS2 a few days ago. Client version 1.3.13, python 2.7 using YaRSS2 1.4.3-2.7. The client runs on Windows 7, the server running the daemon is on Windows 8.1. I don't have any network problems and both connections are wired.

client disconnect.png
client disconnect.png (12.05 KiB) Viewed 3519 times


This disconnect occurs several times a day (twice in the last two hours). It happens regardless of if a secure feed is used or not. It doesn't occur if all of my subscriptions are disabled.

Monberg75
New User
New User
Posts: 2
Joined: Sun Apr 24, 2016 2:27 pm
OS or Distro: Windows 10

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Monberg75 » Fri Nov 18, 2016 10:18 am

This plugin is GREAT!

But i miss a copy of the downloaded torrents. Is there a way to get that?

It seems that the plugin is adding the torrents directly, maybe there is an option to make it make a copy of the torrent files if the 'copy added torrent files to' is set. Or adding the torrentfiles to the 'wathc' folder?

Hope someone can help me here.. I need the torrent files the plugin downloads.

hoppy
New User
New User
Posts: 1
Joined: Wed Nov 30, 2016 8:39 pm
OS or Distro: w10

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby hoppy » Wed Nov 30, 2016 8:43 pm

So, subsciptions are ok, but still the torrents are not downloading. I found these in log: "Failed to download torrent url: ... Exception: Exceeded 30 redirects."


Return to “Plugins”

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests