[Plugin] YaRSS2 - RSS plugin with GTKUI support

Suggest, post, or discuss plugins for Deluge
SirFargo
New User
New User
Posts: 4
Joined: Mon Oct 12, 2015 5:21 pm
OS or Distro: NAS

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby SirFargo » Mon Oct 12, 2015 5:46 pm

bro wrote:
SirFargo wrote:I have the same problems as some of you above. But it worked fine until today. It´s been working for weeks.
But today i got this error-message for one of my rss-feeds.

<urlopen error [errno 1]_ssl.c490: error:14077438:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert internal error>

I have three rss-feeds. And this message only shows for one of them, (altho it is the one i use for most things).
The RSS-feed works fine in my other rss-readers tho.

Anyone know what causes this yet?

*edit*
Im using the latest verson of YaRSS2.

What version of python do you have?

Im running Deluge on my NAS.
My Python-version is 2.7.9

But im running YaRSS2 for 2.6 python. The 2.7-version does not work.

bro
Top Bloke
Top Bloke
Posts: 344
Joined: Sun Aug 28, 2011 6:46 pm
OS or Distro: Ubuntu/FreeBSD
Location: Norway

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby bro » Mon Oct 12, 2015 6:26 pm

SirFargo wrote:Im running Deluge on my NAS.
My Python-version is 2.7.9

But im running YaRSS2 for 2.6 python. The 2.7-version does not work.

How does that work? The 2.6 egg won't load with python 2.7? You mean you use the 2.6 egg locally on the thin client?
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.

SirFargo
New User
New User
Posts: 4
Joined: Mon Oct 12, 2015 5:21 pm
OS or Distro: NAS

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby SirFargo » Mon Oct 12, 2015 7:11 pm

bro wrote:
SirFargo wrote:Im running Deluge on my NAS.
My Python-version is 2.7.9

But im running YaRSS2 for 2.6 python. The 2.7-version does not work.

How does that work? The 2.6 egg won't load with python 2.7? You mean you use the 2.6 egg locally on the thin client?


Beats me. I tried the 2.7-version of 1.4.1 first but it wont show in plugins. When i tried the 2.6-version it just worked.

The 2.6 version is installed both on the nas and on the "thin client" that i use to remotly control deluge on my nas.

SirFargo
New User
New User
Posts: 4
Joined: Mon Oct 12, 2015 5:21 pm
OS or Distro: NAS

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby SirFargo » Tue Oct 13, 2015 8:16 am

Now i tried to remove all my plugins, and install them as i should according to the wiki.

*On my windows computer that runs the thin client i have YaRSS2-1.4.1-py2.6.egg

*On my NAS that runs the "server-version" of deluge i got YaRSS2-1.4.1-py2.7.egg

My NAS python version is 2.7.9.

I removed all the config-files for YaRSS2 to give it a fresh start.
But i still have the same problem.

<urlopen error [Errno 1] _ssl.c:490: error:14077438:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert internal error> (THIS IS NOW FIXED, I FIXED IT BY CHANGING HTTPS TO HTTP IN THE FEED TAB)

This is so frustrating! The plugin worked fine until last saturday...


With my other rss-feed i now have a diffrent issue: (STILL GOT THIS PROBLEM)

(2015-10-13T10:19:18): Unable to decode torrent file! (Success) URL: 'https://****'
(2015-10-13T10:19:18): Failed to add torrent '*******' from url 'https://****'
(2015-10-13T10:19:18): Failed to add '*****'.


Update!
I fixed my urlopen error-problem by changing the https to http in the feeds area in YARSS2. Still have the other problem tho.

Matthias
New User
New User
Posts: 2
Joined: Fri Oct 09, 2015 8:50 pm
OS or Distro: FreeBSD

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Matthias » Tue Oct 13, 2015 5:13 pm

Unfortunately changing to HTTP from HTTPS doesn't work for me as all the URLs in the feed are HTTPS.

emrecnl
New User
New User
Posts: 8
Joined: Wed Oct 07, 2015 10:08 am
OS or Distro: Ubuntu Server

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby emrecnl » Fri Oct 16, 2015 7:14 am

@shinger Yes I added that sltv tag already. But problem is, today it's sltv tomorrow something like let's say bltv comes out deluge will download that torrent too. I can't just set it download exactly matched words and nothing more.
Deluge Host: Ubuntu Server 14.04.03 amd64
Deluge Clients: Windows 7 x64 & Linux Mint 17.2 Cinnamon amd64

Nilysg
New User
New User
Posts: 1
Joined: Sat Nov 07, 2015 11:03 am
OS or Distro: osx

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Nilysg » Sat Nov 07, 2015 11:23 am

I am having the same issues as Mathias - as in getting hit by a SSL Auth error.

Setup:
osx
Deluge v.1.3.12
YaRSS v. 1.4.1

YaRSS2 works flawlessly on non SSL feeds.

Let me know if i can provide futher information to make the debugging easier:-)

/Nilysg

Reesebiz
New User
New User
Posts: 1
Joined: Sun Nov 08, 2015 1:18 pm
OS or Distro: Windows

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby Reesebiz » Sun Nov 08, 2015 1:21 pm

Is it possible to filter based on published date? A set of torrents is released as "My.Favourite.Series - EP197". I only want episodes starting after 100.

bonebox
New User
New User
Posts: 1
Joined: Fri Nov 13, 2015 11:57 pm
OS or Distro: Synology DS414

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby bonebox » Sat Nov 14, 2015 12:06 am

+1 for having this same problem. It was working fine and just recently started throwing this CERTIFICATE_VERIFY_FAILED error. I have not made any updates to Deluge or Python. My NAS is running Python 2.7.9. I was running an older version of YaRSS2 so tried updating to 1.4.2, but still get the same error. Has anyone found a solution yet?
Nilysg wrote:I am having the same issues as Mathias - as in getting hit by a SSL Auth error.

Setup:
osx
Deluge v.1.3.12
YaRSS v. 1.4.1

YaRSS2 works flawlessly on non SSL feeds.

Let me know if i can provide futher information to make the debugging easier:-)

/Nilysg

bro
Top Bloke
Top Bloke
Posts: 344
Joined: Sun Aug 28, 2011 6:46 pm
OS or Distro: Ubuntu/FreeBSD
Location: Norway

Re: [Plugin] YaRSS2 - RSS plugin with GTKUI support

Postby bro » Sat Nov 14, 2015 11:00 am

As always, the best way you can help me is to make it as easy as possible for me to reproduce the issue. There could be a range of different reasons causing similar issues which is why you should always try to provide the information necessary to reproduce the issue.
When reporting issues, please include any relevant information such as OS (and version), python version (for Windows users this depends on which Deluge installer was used), Deluge version and plugin version.


Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 5 guests