[Plugin] Copy Completed plugin

Suggest, post, or discuss plugins for Deluge
Posts: 13
Joined: Sun Nov 20, 2016 1:16 pm
OS or Distro: Windows 10

Re: [Plugin] Copy Completed plugin

Postby Robin » Mon Nov 21, 2016 8:37 pm

this update, exactly what i needed!! thank you so much, tested it on windows 10 and works like a charm!

Posts: 13
Joined: Tue Dec 27, 2016 1:42 pm
OS or Distro: windows

Re: [Plugin] Copy Completed plugin

Postby seanvree » Sun Jan 08, 2017 8:18 am

Yeah, so just so I"m clear, there is no way to only copy/move a completed torrent based on the watch folder or label? It's all or none, correct?

New User
New User
Posts: 1
Joined: Mon Mar 27, 2017 8:40 am
OS or Distro: Ubuntu v16.04.2

Re: [Plugin] Copy Completed plugin

Postby POWerSUrgeSW3 » Mon Mar 27, 2017 8:52 am

ult.nrg wrote:Updated this plugin to append label to the end of the directory.

E.g. if your Copy folder is C:\Downloads, your label is "Movies" and you've ticked "Append Label" in settings, it will copy the files to C:\Downloads\Movies

Have run and tested it on Windows. If you have issues please attach the log file.


Download: https://github.com/ultnrg/deluge-CopyCo ... -py2.7.egg

Thank you for working on this, it's great. I tried using this on my QuickBox v2.4.9 with Deluge v1.3.14 (Which I only use, nothing else on the box) installed Ubuntu v16.04.2. I was able to install the plugin, and it actually shows up in my "Catagories" now, unless the v0.6. I have my 'Copy to path', which is what I normally use when issuing a 'cp -a' command when I manually copy files over... but nothing seems to copy over when it's done downloading and seeing. Still have to manually copy downloaded torrents over.

I used this plugin when I was running a Windows box, but that thing kept locking up and just having fits. When I found out about QuickBox and it runs on Linux I tried it... and haven't looked back. But this has been the one missing part, because nothing else seems to work as seemlessly like this plugin did when I was on Windows. Which is why when I finally saw this update I was hoping it would work.


My box is solid, I've been using it for about 4 months without issue, though since I've been on Linux I haven't been able to use this plugin. So I know it's not a path issue there or something weird on that end. Maybe it's v1.3.14? Any suggestions.

Either way thanks for keeping the plugin alive and the thread going!

Return to “Plugins”

Who is online

Users browsing this forum: No registered users and 12 guests