Page 1 of 1

[Plugin] conkyDeluge

Posted: Tue Apr 06, 2010 2:16 pm
by Cas
This is simply a post in order to make the Deluge community aware of this handy conky script and the fact the developer, kaivalagi, is no longer maintaining it.

I have not had time to test it but with a recent patch from here it should work with latest Deluge 1.2.3

Kaivalagi has an ubuntu forum thread for the script here: http://ubuntuforums.org/showthread.php?t=946664

Re: [Plugin] Conky Deluge Script

Posted: Sun Nov 14, 2010 11:03 pm
by Cas
This has been updated by someone else and given its own PPA repository called conkydeluge so making it easy to install and keep updated on ubuntu. Just tested with 10.10 and Deluge 1.3.1 and seems to work fine.

Note: There is bug, where if the script cannot find a running deluge it hangs rather than close gracefully and you could end up with lots of conkydeluge scripts needing killed. I might have a look at trying to fix this at some point.

I am not sure why there is such a convoluted install description on the forum as all that is required is to add the PPA repo and install

Code: Select all

sudo add-apt-repository ppa:conkyhardcore/ppa
sudo apt-get update && sudo apt-get install conkydeluge


By adding this repository you will also get access to some other quite useful conky scripts: https://launchpad.net/~conkyhardcore/+archive/ppa

Re: [Plugin] Conky Deluge Script

Posted: Thu Jul 07, 2011 8:02 pm
by Cas
Fixed the error in the script here: https://github.com/cas--/conkyDeluge

To update you can simply replace the installed conkyDeluge.py located here:

Code: Select all

/usr/share/conkydeluge/conkyDeluge.py