Deluge 2.0 Beta 1

Suggestions and discussion of future versions
toolazy
Member
Member
Posts: 15
Joined: Mon Nov 20, 2017 7:05 pm
OS or Distro: Ubuntu 17.04

Re: Deluge 2.0 Beta 1

Postby toolazy » Thu Nov 23, 2017 9:18 am

i tried the 1.3-stable from git and when i do deluged -d as the user thats running it i get and it shuts down

[ERROR ] 10:16:31 main:248 'module' object has no attribute 'session_settings'
Traceback (most recent call last):
File "/opt/deluge/deluge/main.py", line 241, in start_daemon
Daemon(options, args)
File "/opt/deluge/deluge/core/daemon.py", line 147, in __init__
read_only_config_keys=read_only_config_keys)
File "/opt/deluge/deluge/core/core.py", line 106, in __init__
self.settings = lt.session_settings()
AttributeError: 'module' object has no attribute 'session_settings'

Cas
Top Bloke
Top Bloke
Posts: 3468
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Deluge 2.0 Beta 1

Postby Cas » Thu Nov 23, 2017 10:12 am

toolazy wrote:deluged -V
deluged 2.0b1
libtorrent: 1.2.0.0
Python: 2.7.13
OS: Linux Ubuntu 17.04 zesty

exceptions.AttributeError: 'torrent_handle' object has no attribute 'resolve_countries'


Can you create a ticket for this please. In the meantime I would suggest using the develop PPA.

crafty35a wrote:Any chance we can get a new build posted with the Peer ID fixed? This is preventing me from using the beta at all. Even my trackers that would allow the Deluge beta are blocking it because Bitlord is blacklisted.

I will do this soon and once a few other issues are resolved make another beta release.

toolazy wrote:e deluge-web wont start anymor

deluge-web now daemonizes by default so you will need to use the `-d` option with unit files.

toolazy
Member
Member
Posts: 15
Joined: Mon Nov 20, 2017 7:05 pm
OS or Distro: Ubuntu 17.04

Re: Deluge 2.0 Beta 1

Postby toolazy » Thu Nov 23, 2017 11:19 am

Cas wrote:
toolazy wrote:deluged -V
deluged 2.0b1
libtorrent: 1.2.0.0
Python: 2.7.13
OS: Linux Ubuntu 17.04 zesty

exceptions.AttributeError: 'torrent_handle' object has no attribute 'resolve_countries'


Can you create a ticket for this please. In the meantime I would suggest using the develop PPA.

crafty35a wrote:Any chance we can get a new build posted with the Peer ID fixed? This is preventing me from using the beta at all. Even my trackers that would allow the Deluge beta are blocking it because Bitlord is blacklisted.

I will do this soon and once a few other issues are resolved make another beta release.

toolazy wrote:e deluge-web wont start anymor

deluge-web now daemonizes by default so you will need to use the `-d` option with unit files.


ok i'll fix a ticket. but i did have problems with the develop/ppa to. i'll get back with info and a ticket

toolazy
Member
Member
Posts: 15
Joined: Mon Nov 20, 2017 7:05 pm
OS or Distro: Ubuntu 17.04

Re: Deluge 2.0 Beta 1

Postby toolazy » Fri Nov 24, 2017 6:24 am

dont seem to do anything "bad" but in the log i get i have -L warning

[WARNING ][deluge.core.core :529 ] Using deprecated session status key num_peers, please use peer.num_peers_connected
07:21:22.790 [WARNING ][deluge.core.core :529 ] Using deprecated session status key dht_nodes, please use dht.dht_nodes

and i got it working with the error i posted a few post back.

http://dev.deluge-torrent.org/ticket/3132

now i just need to see so that the torrent files get removed and the files goes from ./downloads to ./_done when it gets completed

toolazy
Member
Member
Posts: 15
Joined: Mon Nov 20, 2017 7:05 pm
OS or Distro: Ubuntu 17.04

Re: Deluge 2.0 Beta 1

Postby toolazy » Thu Nov 30, 2017 11:07 am

did post this before. but is it deluge or libtorrent that need to be changed for this message

07:41:52.837 [WARNING ][deluge.core.core :529 ] Using deprecated session status key num_peers, please use peer.num_peers_connected
07:41:52.838 [WARNING ][deluge.core.core :529 ] Using deprecated session status key dht_nodes, please use dht.dht_nodes

running latest "i think" with no problems.

$ deluged -V
deluged 2.0b2.dev37
libtorrent: 1.1.5.0
Python: 2.7.13
OS: Linux Ubuntu 17.04 zesty

Spadge
Leecher
Leecher
Posts: 99
Joined: Sat Dec 13, 2008 4:17 pm

Re: Deluge 2.0 Beta 1

Postby Spadge » Tue Dec 26, 2017 1:03 am

Is anyone else seeing speed limits ignored?

Client: 2.0.0.dev7125
Server: 2.0.0.dev7125

libtorrent: 1.1.5.0

Spadge
Leecher
Leecher
Posts: 99
Joined: Sat Dec 13, 2008 4:17 pm

Re: Deluge 2.0 Beta 1

Postby Spadge » Sat Dec 30, 2017 1:02 pm

Max DL bandwidth set to 4096K/s, currently DLing at 6+MB/s

There's definitely something up with speed limits.

I'm now trying with setting a per-torrent max speed as well as a global speed. First glance appears to show it adhering to that.

Spadge
Leecher
Leecher
Posts: 99
Joined: Sat Dec 13, 2008 4:17 pm

Re: Deluge 2.0 Beta 1

Postby Spadge » Wed Jan 03, 2018 5:00 pm

RE: Changeset f57286 "#3121 Fix the peer-id to be unique"?

I've just spotted that I can now connect to trackers I was previously banned from.

Thanks for all your time and work.

ElectronicWar
New User
New User
Posts: 6
Joined: Wed Sep 04, 2013 3:21 pm
OS or Distro: Raspbian Stretch

Re: Deluge 2.0 Beta 1

Postby ElectronicWar » Mon Jan 15, 2018 8:12 pm

Trying to build Deluge 2 from Git develop on Debian Stretch (raspbian).
I had 0 issues building 1.3 from source for many years now, but 2.0 fails on me.

Trying to use the develop PPA fails as it requires the libssl1.0.0 package to be version 1.0.2, but debian has libssl1.0.2 for that.

python setup.py build fails with the following error:

Code: Select all

  import libtorrent as lt
Traceback (most recent call last):
  File "setup.py", line 518, in <module>
    entry_points=_entry_points
  File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "setup.py", line 363, in run
    from deluge._libtorrent import LT_VERSION
  File "/home/pi/inst/deluge/deluge/_libtorrent.py", line 31, in <module>
    raise ImportError('Deluge %s requires libtorrent >= %s' % (get_version(), REQUIRED_VERSION))
  File "/home/pi/inst/deluge/deluge/common.py", line 83, in get_version
    return pkg_resources.require('Deluge')[0].version
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 963, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 849, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'Deluge' distribution was not found and is required by the application



Beside that it gets warnings from lextab/slimit and boost, but those do not break the compile progress.

Am I missing something?

Code: Select all

import libtorrent
libtorrent.version

returns 1.1.1.0, so the python package is available and working.
Attachments
compile-full-output.txt
(41.06 KiB) Downloaded 2 times


Return to “Development”

Who is online

Users browsing this forum: No registered users and 5 guests