Deluge 1.3.15 Corruption of Proxy Settings has no effect

General support for problems installing or using Deluge
tsc
New User
New User
Posts: 3
Joined: Tue Dec 26, 2017 10:16 am
OS or Distro: Debian/Jessie

Deluge 1.3.15 Corruption of Proxy Settings has no effect

Postby tsc » Tue Dec 26, 2017 10:25 am

I am running Deluge 1.3.15 on Debian Jessie and encountered the following issue.

I set up a Socks5 proxy with my Windscribe credentials. I then intentionally corrupted those credentials by providing the wrong password and a non-existent host. I was still able to download the Ubuntu 17.10 torrent using these bogus credentials. I would have thought that my inability to connect to the proxy server would have blocked the file transfer, but that was not the case. What gives?

User avatar
gderf
Leecher
Leecher
Posts: 78
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

Re: Deluge 1.3.15 Corruption of Proxy Settings has no effect

Postby gderf » Wed Dec 27, 2017 3:47 am

Did you restart deluged after making those changes to the proxy settings?

If you did not restart deluged, and you had an existing open connection to the proxy, then that connection will be used (with the valid host and password).

tsc
New User
New User
Posts: 3
Joined: Tue Dec 26, 2017 10:16 am
OS or Distro: Debian/Jessie

Re: Deluge 1.3.15 Corruption of Proxy Settings has no effect

Postby tsc » Wed Dec 27, 2017 6:40 pm

I tried both restarting the daemon and restarting my whole device after changing the proxy settings. Neither restart made a difference. I was still able to download the file without a problem.

User avatar
gderf
Leecher
Leecher
Posts: 78
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

Re: Deluge 1.3.15 Corruption of Proxy Settings has no effect

Postby gderf » Wed Dec 27, 2017 10:35 pm

I can not replicate the problem here. Running 1.3.15 on OpenMediaVault 3.x (Built on Debian Jessie 8.x).

All I get when corrupting the proxy host is "Error: Host not found (authoritative)" when looking at the Tracker Status on the Status Tab.

Have you installed the ltconfig plugin and enabled anonymous_mode and force_proxy ?

tsc
New User
New User
Posts: 3
Joined: Tue Dec 26, 2017 10:16 am
OS or Distro: Debian/Jessie

Re: Deluge 1.3.15 Corruption of Proxy Settings has no effect

Postby tsc » Thu Dec 28, 2017 3:42 am

I've since done that (installed itconfig and enabled anonymous_mode and force_proxy). Now I get an authentication errors when I corrupt my proxy settings. What is happening when those libtorrent settings are not enabled? Does deluge fall back on my real IP if a proxy server cannot be reached?

BTW, @gderf thank you for looking into this.

User avatar
gderf
Leecher
Leecher
Posts: 78
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

Re: Deluge 1.3.15 Corruption of Proxy Settings has no effect

Postby gderf » Thu Dec 28, 2017 4:55 pm

I am fairly certain that if you are not connected to the proxy and you are able to have torrents running, they are using your real IP address.

You might try going to the original configuration with the corrupted proxy host and without those ltconfig settings set, and download that torrent again. While it's running try running netstat -an in a shell. You should see the IP addresses of all your connections, many of which would be the peers you are connected to for that torrent.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 16 guests