Error on install - Multiple Daemons and Libtorrent Error

General support for problems installing or using Deluge
takethecann0lis
New User
New User
Posts: 1
Joined: Fri Dec 01, 2017 8:52 pm
OS or Distro: Linux raspberrypi 4.

Error on install - Multiple Daemons and Libtorrent Error

Postby takethecann0lis » Fri Dec 01, 2017 10:29 pm

Hi, I'm installing Deluge on my Raspberry Pi 3 and I'm running into issues. Hoping for some help.

Linux raspberrypi 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux
Deluged: 1.3.13
Libtorrent: 1.1.1.0

Note: when I try to look up the version of deluged, I get the following return

Code: Select all

deluged --version
deluged: 1.3.13
/usr/lib/python2.7/dist-packages/deluge/_libtorrent.py:59: RuntimeWarning: to-Python converter for boost::shared_ptr<libtorrent::alert> already registered; second conversion method ignored.
  import libtorrent as lt
libtorrent: 1.1.1.0


When I run Deluged I get the following return

Code: Select all

pi@raspberrypi:~ $ deluged deluge-web
pi@raspberrypi:~ $ [ERROR   ] 17:28:30 main:243 There is a deluge daemon running with this config directory!
[ERROR   ] 17:28:30 main:244 You cannot run multiple daemons with the same config directory set.
[ERROR   ] 17:28:30 main:245 If you believe this is an error, you can force a start by deleting /home/pi/.config/deluge/deluged.pid.


Any help would be greatly appreciated :)

Return to “Support”

Who is online

Users browsing this forum: Bing [Bot] and 16 guests