Did something silly before reading

General support for problems installing or using Deluge
HackitZ
New User
New User
Posts: 4
Joined: Sun Nov 26, 2017 9:07 pm
OS or Distro: debian

Did something silly before reading

Postby HackitZ » Sun Nov 26, 2017 9:16 pm

Ok i just did something silly and now can't change the settings.
i was tired of the time outs and don't remember the name of the setting(web time out) but the end result when i open deluge from my web browser the log in time is now set too zero so i cant log in. thought zero might have been never.
sorry for the vagueness on my description if you need more info please ask.

i thought i could go into the core.conf but i cant find the setting, is there another way to change settings without the gui?

shamael
Super Seeder
Super Seeder
Posts: 297
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Did something silly before reading

Postby shamael » Mon Nov 27, 2017 9:22 am

Maybe the web.conf located in the same place?
Do not forget to stop respective daemons prior any change.

sinaptika
Member
Member
Posts: 23
Joined: Thu Apr 27, 2017 6:23 pm
OS or Distro: Linux/Alpine,Debian

Re: Did something silly before reading

Postby sinaptika » Mon Nov 27, 2017 2:38 pm

shamael wrote:Do not forget to stop respective daemons prior any change.

Stop deluge-web first!!

Then edit web.conf:
Look around line 25-26 and change session timeout to (if I may suggest) a non zero value :)

Code: Select all

"session_timeout": 3600,

HackitZ
New User
New User
Posts: 4
Joined: Sun Nov 26, 2017 9:07 pm
OS or Distro: debian

Re: Did something silly before reading

Postby HackitZ » Tue Nov 28, 2017 1:52 am

Well i have done that and still cant login. no error or time out just keeps showing login box. i did stop and start the service.

shamael
Super Seeder
Super Seeder
Posts: 297
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Did something silly before reading

Postby shamael » Tue Nov 28, 2017 9:15 am

Well I see 2 options: rename the profile and create a new one (you can keep the loaded torrents) or try the below procedures. Both cases request a backup of your profile (".config/deluge" wherever it's located).

I assume here you know how to locate you Deluge profile, you edited the file already (the good one?). If not just tell us.
The new profile seems the best way but the below steps helped me i the past for a similar case and can rapidly tested.

After the backup (adapt with your own path)
#stop daemons
sudo systemctl stop deluged deluge-web

#copy the local key, the 1line of auth
cat .config/deluge/auth

#edit .config/deluge/hostlist.conf.1.2
nano .config/deluge/hostlist.conf.1.2

#replace the $YOURKEY with the one of the auth file

Code: Select all

{
  "file": 1,
  "format": 1
}{
  "hosts": [
    [
      "$YOURKEY",
      "127.0.0.1",
      58846,
      "",
      ""
    ]
  ]
}


#start daemons
sudo systemctl start deluged deluge-web

HackitZ
New User
New User
Posts: 4
Joined: Sun Nov 26, 2017 9:07 pm
OS or Distro: debian

Re: Did something silly before reading

Postby HackitZ » Sat Dec 02, 2017 2:27 am

tnx back up and running, i wish could i could leave the session timeout to infinite


Return to “Support”

Who is online

Users browsing this forum: No registered users and 7 guests