Deluge not connecting to peers?

General support for problems installing or using Deluge
weebed
New User
New User
Posts: 1
Joined: Sun Oct 15, 2017 1:31 am
OS or Distro: Linux Mint

Deluge not connecting to peers?

Postby weebed » Sun Oct 15, 2017 1:44 am

I'd like to begin this by saying that I am in no way a professional. I have no clue what I'm doing. Please hand hold as strong as possible.

So, I have a seedbox that has 1.3.15 on it. My speeds on said seedbox are:
Download: 415.81 Mbit/s
Upload: 149.58 Mbit/s

Speed is not an issue for me. Only when I begin torrenting do I experience some issues.
For example; I have a torrent with over 250 peers (private tracker) however, I am only connected to 16 of those peers. Also, my UL speed on said torrent is around 250KiB/s. (My download speed on the other hand is 60 MiB/s completely fine with that.)

What is the problem here?

My settings are:
Maximum Connections: 500

Maximum Upload Slots: -1

Maximum Download Speed (KiB/s): -1

Maximum Upload Speed (KiB/s): -1

Maximum Half-Open Connections: 15

Maximum Connection Attempts per Second: 20

Ignore limits on local network and rate limit ip overhead are both disabled.


Is there a specific guide that I have to follow in order to increase my UL speed?

shamael
Super Seeder
Super Seeder
Posts: 278
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Deluge not connecting to peers?

Postby shamael » Mon Oct 16, 2017 1:22 pm

Hi,

Well it all depends of the number of seeders for the torrent. The leecher connects to the maximum number of seeder so reaching the max UP speed is more about being one of the few seeders or an early seeder (aka having the file completed ASAP after publishing).

On a private tracker the per torrent upload slot (with max "maximum Upload Slots: -1") per torrent has, for me, as sweet spot around 10-15. But you can try higher. In any way you will reach a limit (computer, router) if you set the total connection number too high.

Have you checked the ltconfig plugin? It maximizes a lot of value but should not be blinded applied, it's all about your hardware. (see the forum for more)


Return to “Support”

Who is online

Users browsing this forum: No registered users and 7 guests