Deuged, libtorrent, raspian stretch all the errors

General support for problems installing or using Deluge
AceScottie
New User
New User
Posts: 7
Joined: Thu Aug 17, 2017 3:39 pm
OS or Distro: Debian

Deuged, libtorrent, raspian stretch all the errors

Postby AceScottie » Fri Aug 18, 2017 5:38 pm

Hello.
I am trying install deluge and deluge-web on a raspberry pi 3 with raspian stretch.

Main problem is libtorren, as i have seen a lot of people know of this error and are simply saying downgrade to libtorrent 1.0.9.
My problem is how do i do that ?

I have tried about a million and one things to get it working,
downloading libtorrent 1.0.9 and using python setup.py install = error b2: build failed
running through http://dev.deluge-torrent.org/wiki/Inst ... ian/Jessie still installs libtorrent v1.1.11

full error is something to do with "import libtorrent as lt"

is there a command for installing libtorrent 1.0.9 that is not:
apt-get install python-libtorrent=1.0.9
apt-get install python-libtorrent=0.16.18.0
apt-get install libtorrent-rasterbar9
apt-get install libtorrent-rasterbar8
apt-get install libtorrent-rasterbar9=1.0.9
apt-get install libtorrent-rasterbar8=1.0.9
install -t trusty libtorrent-rasterbar8 python-libtorrent

been trying everything i can think of for about 3 hours with no luck at all.
I have a debian client running perfectly with deluge 1.3.10 and libtorrent 0.16.18.0 but i cant seem to recreate this on the Pi 3

Romko28
New User
New User
Posts: 2
Joined: Sun Aug 20, 2017 12:48 pm
OS or Distro: Raspbian

Re: Deuged, libtorrent, raspian stretch all the errors

Postby Romko28 » Sun Aug 20, 2017 1:04 pm

Hi,

I've got the same issues. However, despite these errors, deluge seems to work Ok.

Romko28
New User
New User
Posts: 2
Joined: Sun Aug 20, 2017 12:48 pm
OS or Distro: Raspbian

Re: Deuged, libtorrent, raspian stretch all the errors

Postby Romko28 » Sun Aug 20, 2017 7:24 pm

Update:

Ok, it seems that my deluge fails to create a new file when I add a new torrent. Existing torrents work Ok.
Will be looking for a solution.

shamael
Super Seeder
Super Seeder
Posts: 269
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Deuged, libtorrent, raspian stretch all the errors

Postby shamael » Mon Aug 21, 2017 9:29 am

Hi AceScottie

I'm actually running the PPA version on a Debian Jessie, RPI too, you can safely use libtorrent 1.0.11. The link you mention is for Debian Jessie
matching Ubuntu trusty. Debian stretch has a match with Ubuntu xenial so we can give a try to:

1/ Delete any Deluge and libtorrent package installed in the Debian stretch (sudo dpkg -l to be sure after removal after apt-get remove & autoremove)
2/ add following lines to APT source (sudo nano /etc/apt/sources.list)

deb http://ppa.launchpad.net/deluge-team/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/deluge-team/ppa/ubuntu xenial main

3/ sudo apt-get update
4/ sudo apt-get install -t xenial libtorrent-rasterbar8
5/ sudo apt-get install -t xenial deluged deluge-web deluge-console

Tvich
Member
Member
Posts: 33
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Deuged, libtorrent, raspian stretch all the errors

Postby Tvich » Tue Aug 22, 2017 9:00 am

shamael wrote:3/ sudo apt-get update
4/ sudo apt-get install -t xenial libtorrent-rasterbar8
5/ sudo apt-get install -t xenial deluged deluge-web deluge-console


Although this is a great idea, i'm pretty sure there might be some problems, especially with boost and openssl dependencies.
I'l try installing from ppa on raspbian stretch (and variations) today, mostly because I think manually building libtorrent 1.0.11 on pi3 won't be fun.

@AceScottie
If you want, you can install docker on your pi3. I can have an deluged+deluge-web/ubuntu armhf image ready for you quickly.

shamael
Super Seeder
Super Seeder
Posts: 269
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Deuged, libtorrent, raspian stretch all the errors

Postby shamael » Tue Aug 22, 2017 10:03 am

Give it a try, I think you will be happy afterward :). For the dependencies you can refer to http://dev.deluge-torrent.org/wiki/Installing/Source#DebianUbuntuDependencies. It's true I did it prior the PPA install at the time I compiled both libtorrent and Deluge myself.

AceScottie
New User
New User
Posts: 7
Joined: Thu Aug 17, 2017 3:39 pm
OS or Distro: Debian

Re: Deuged, libtorrent, raspian stretch all the errors

Postby AceScottie » Tue Aug 22, 2017 2:18 pm

deb http://ppa.launchpad.net/deluge-team/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/deluge-team/ppa/ubuntu xenial main

3/ sudo apt-get update
4/ sudo apt-get install -t xenial libtorrent-rasterbar8
5/ sudo apt-get install -t xenial deluged deluge-web deluge-console

This worked perfectly, no errors or bugs that i can see at all.
spent 3 hours trying to figure this out and you solve it in 2 minuets :)

shamael
Super Seeder
Super Seeder
Posts: 269
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Deuged, libtorrent, raspian stretch all the errors

Postby shamael » Tue Aug 22, 2017 3:45 pm

Great ;)

Tvich
Member
Member
Posts: 33
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Deuged, libtorrent, raspian stretch all the errors

Postby Tvich » Tue Aug 22, 2017 5:40 pm

You guys sure you have everything working?

1. There should be errors when adding ppa without the gpg key.
2. Even after adding the gpg key, you should get:
The following packages have unmet dependencies:
"libtorrent-rasterbar8 : Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
E: Unable to correct problems, you have held broken packages."


@shamael AceScottie
Did you do anything else, that was not writen here?
I'm probably doing something wrong, but I can't reproduce installing from xenial ppa.

shamael
Super Seeder
Super Seeder
Posts: 269
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Deuged, libtorrent, raspian stretch all the errors

Postby shamael » Tue Aug 22, 2017 8:02 pm

An error about the gpg key is expected, key was not imported but does not stop anything to work.
What's your output of

Code: Select all

sudo dpkg -l|grep libssl
?

Mine is
ii libssl-dev:armhf 1.0.1t-1+deb8u6 armhf Secure Sockets Layer toolkit - development files
ii libssl1.0.0:armhf 1.0.1t-1+deb8u6 armhf Secure Sockets Layer toolkit - shared libraries

If you don't have the package try to install "libssl-dev" and test again.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 11 guests