deluge-web not starting

General support for problems installing or using Deluge
Ansem
Member
Member
Posts: 27
Joined: Sat Aug 06, 2016 7:14 pm
OS or Distro: Windows

deluge-web not starting

Postby Ansem » Fri Jun 16, 2017 1:59 pm

HI everyone,
since I changed the webgui port from 8112 to 2 the deluge-web daemon doesn-t start anymore!
if I try to start it manually it ask me for the default password and doesn't show me the torrent that I was downloading.

Can anyone help me? where I can find the config file on linux and restore the correct port hoping that it will be enough?

User avatar
hrip6
Member
Member
Posts: 10
Joined: Fri Jun 16, 2017 1:39 pm
OS or Distro: Debian

Re: deluge-web not starting

Postby hrip6 » Fri Jun 16, 2017 2:08 pm

That's maybe because your deamon has been running from different user. Did you run them in the same user as when you downloading?
Image Patreon: http://patreon.com/deluge_cas
Image Contact me: http://forum.deluge-torrent.org/ucp.php?i=pm&mode=compose&u=129152

Ansem
Member
Member
Posts: 27
Joined: Sat Aug 06, 2016 7:14 pm
OS or Distro: Windows

Re: deluge-web not starting

Postby Ansem » Fri Jun 16, 2017 4:46 pm

yeah, it's beacuse I launched deluge-web as root, while deluged is running bu deluge-+ (a user dedicated for deluge).
How can I change the settings of deluge so that I can run it again? :(

User avatar
hrip6
Member
Member
Posts: 10
Joined: Fri Jun 16, 2017 1:39 pm
OS or Distro: Debian

Re: deluge-web not starting

Postby hrip6 » Fri Jun 16, 2017 11:47 pm

If you like to keep the old downloaded torrent, login to user "deluge-+" then run deluge-web --fork. Or you like to run all the deluge in root, then kill the deluge daemon in other user and run them again under root user. :mrgreen:
Image Patreon: http://patreon.com/deluge_cas
Image Contact me: http://forum.deluge-torrent.org/ucp.php?i=pm&mode=compose&u=129152

Tvich
Member
Member
Posts: 33
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: deluge-web not starting

Postby Tvich » Sat Jun 17, 2017 2:01 am

Ansem wrote:HI everyone,
since I changed the webgui port from 8112 to 2


Only root can bind to ports below 1024.

Stop deluge-web (make sure it is stoped), locate file web.conf, open it with your editor and change "port": 2, to "port": 8112,.

Ansem
Member
Member
Posts: 27
Joined: Sat Aug 06, 2016 7:14 pm
OS or Distro: Windows

Re: deluge-web not starting

Postby Ansem » Sat Jun 17, 2017 1:53 pm

Thanks a lot! didn't know that ports below 1024 are binded to root :(


Return to “Support”

Who is online

Users browsing this forum: No registered users and 10 guests